XmRig monero v7 nicehash.

I'm having trouble mining to nicehash with xmrig on my CPU

So I've got the following in the settings of my wallet.
Wallet and worker template: %DWAL%.%WORKER_NAME%
Pool URL: cryptonightv7.usa.nicehash.com:3355
Config override: "nicehash"

I guess hiveos is not translating
nicehash
into the proper format needed for the command line options. I've also tried
"nicehash" : true
but I get no hashrate. How am I supposed to enter the additional options here? In the example it says to do the parameters like
"max-cpu-usage": 50

Comments

  • What exactly is your error? I think that for CN v7 you should use port 3363 when defining pool.
  • edited June 9
    @givo totally right!

    For now NiceHash has several pools for different cryptonight variants

    Cryptonight (now profitable only for ASICs)
    Europe stratum+tcp://cryptonight.eu.nicehash.com:3355
    Europe (secure) - stratum+ssl://cryptonight.eu.nicehash.com:33355
    USA - stratum+tcp://cryptonight.usa.nicehash.com:3355
    USA (secure) -stratum+tcp://cryptonight.usa.nicehash.com:3355
    ....
    and so on

    CryptonightV7 (Monero, Electroneum, ...)
    Europe stratum+tcp://cryptonightv7.eu.nicehash.com:3363
    USA stratum+tcp://cryptonightv7.eu.nicehash.com:3363
    ....

    Cryptonight Heavy (Sumokoin, Ryo, Loki, Have, etc...)
    Europe stratum+tcp://cryptonightheavy.eu.nicehash.com:3364
    USA stratum+tcp://cryptonightheavy.usa.nicehash.com:3364
    ....

    Full list of NiceHash pools you can always get from https://www.nicehash.com/cpu-gpu-mining
  • I've put every cryptonight URL I could find in my settings for this wallet trying to get this to work, and I made a typo in this post. This is what I get -
     * VERSIONS:     XMRig/2.6.2 libuv/1.20.2 gcc/5.4.0
     * CPU:          AMD A4-5000 APU with Radeon(TM) HD Graphics     (1) x64 AES-NI
     * CPU L2/L3:    4.0 MB/0.0 MB
     * THREADS:      2, cryptonight, av=0, donate=1%
     * POOL #1:      cryptonightv7.usa.nicehash.com:3363
     * API BIND:     0.0.0.0:60050
     * COMMANDS:     hashrate, pause, resume
    [2018-06-11 08:24:27] READY (CPU) threads 2(2) huge pages 2/2 100% memory 4.0 MB
    [2018-06-11 08:25:31] speed 2.5s/60s/15m n/a n/a n/a H/s max: n/a H/s
    

    If I put the setting
    nicehash
    
    into the config override I get an error about invalid syntax. So I am trying "nicehash": true in the config override and it doesn't seem to do anything.
  • If you go to https://config.xmrig.com/ you can create json config file for your exact need. Since I am not using xmrig, I can only comment on what I read there - you need to put this "nicehash": true within "pools" segment of config file.

    You can try to start the miner from command line and work your way from there. Once you start it that way - try creating config file, and then you can try through HiveOS dashboard.
  • How do I get "nicehash": true into the pool section via the hiveos gui?
  • coreyman wrote: »
    How do I get "nicehash": true into the pool section via the hiveos gui?
    This option add to config file by HiveOS if nicehash address found in pool URL .
  • edited June 13
    Thanks @HaloGenius I see that now. I am still having trouble getting it to mine anything be that cryptonight or cryptonightv7. Here is my current configuration file and my output.
    * VERSIONS:     XMRig/2.6.2 libuv/1.20.2 gcc/5.4.0
     * CPU:          AMD A4-5000 APU with Radeon(TM) HD Graphics     (1) x64 AES-NI
     * CPU L2/L3:    4.0 MB/0.0 MB
     * THREADS:      2, cryptonight, av=0, donate=1%
     * POOL #1:      cryptonight.usa.nicehash.com:3355
     * API BIND:     0.0.0.0:60050
     * COMMANDS:     hashrate, pause, resume
    [2018-06-12 20:45:21] READY (CPU) threads 2(2) huge pages 2/2 100% memory 4.0 MB
    [2018-06-12 20:46:25] speed 2.5s/60s/15m n/a n/a n/a H/s max: n/a H/s
    [2018-06-12 20:47:25] speed 2.5s/60s/15m n/a n/a n/a H/s max: n/a H/s
    
    {
      "algo": "cryptonight",
      "av": 0,
      "background": false,
      "colors": true,
      "cpu-affinity": null,
      "cpu-priority": null,
      "donate-level": 1,
      "log-file": null,
      "max-cpu-usage": 75,
      "print-time": 60,
      "retries": 5,
      "retry-pause": 5,
      "safe": false,
      "syslog": false,
      "threads": null,
      "pools": [
        {
          "url": "cryptonight.usa.nicehash.com:3355",
          "user": "<ADDRESSOBSCURED>",
          "pass": "x",
          "use_nicehash": true,
          "keepalive": true
        }
      ],
      "api": {
        "port": 60050,
        "access-token": null,
        "worker-id": null
      }
    }
    
Sign In or Register to comment.