How to OC locally ?

How to OC directly from hive os locally without web?
Tagged:

Comments

  • edited March 8
    It's not recommended but can be done
    1) Method using config file
    /hive-config
    AMD cards - config file: amd-oc.conf tool: amd-oc
    NVidia crads config file: nvidia-oc.conf tool: nvidia-oc

    After reboot file will be overwritten

    2) Method using OC tools
    it's more difficult and complex method
    NVIdia cards - nvidia-smi
    AMD cards - amdcovc, wolfamdctrl
  • Can I write a detailed 'How to' guide?

    In order to achieve persistence on the applied OC, you have to modify system files (I don't know if that is allowed here but most certainly not recommended) but I ran into some limitations of the web OC tool (@HaloGenius, I wrote to you about it) and had to hack it up to make it work.

    Green Signal?
  • Can I write a detailed 'How to' guide?

    I would love one :) I've also ran into some limitations of the web oc.
  • edited March 10
    Can I write a detailed 'How to' guide?

    Green Signal?
    Yes you can - it's not taboo. But you must write in capital letters for users, some info such as
    1. it's not recommended if don't know how it works
    2. all of you doing - doing at own risk
  • Check this out, it's for AMD, but if you have little knowledge about linux. you could extrapolate how to do the same for nvidia.
    https://www.reddit.com/user/1stnoblegas/comments/84gg33/hiveos_guide_how_to_manually_overclockundervolt/
  • How to Overclock/Undervolt manually:
    We will use the wolfamdctrl tool to do this. Take the card 0 from figure 1 as an example. We want core/memory/voltage settings to be 1200/1500/900 respectively, while mining. You will use values that work for your GPU, this is an example.
    We know GPU ID is 0.
    We want to OC memory P-state 2 to 1500
    Core P-state 7 to 1200
    And the corresponding volt-state 8 to 900
    We want fan-speed to be at a constant 45% This is how we'll achieve it

    wolfamdctrl -i 0 --mem-state 2 --mem-clock 1500 --core-state 7 --core-clock 1500 --volt-state 8 --vddc-table-set 900 --set-fanspeed 45

    I guess it should be --core-clock 1200 not 1500 if I got it right (sorry to point it out, you know that code review habit :-))
  • @Jcomp You are absolutely right, I'll make the correction.
  • HaloGenius wrote: »
    @1stnoblegas, nice job

    ditto, very detailed! awesome work.
Sign In or Register to comment.