http://api.hiveos.farm is not working and cannot change rig.conf to other working URLs

net-test results:
Checking connection to Hive servers:
                                                                                                                                       
>>> api.hiveos.farm
nslookup api.hiveos.farm                                        [OK]
ping api.hiveos.farm                                            [OK]
curl http://api.hiveos.farm                                     [FAIL]
HTTP connection failed. Please check Firewall rules or connection setup.
curl https://api.hiveos.farm                                    [FAIL]
HTTPS (SSL) connection failed. Please check Firewall rules or connection setup.
curl https://api.hiveos.farm:8443                               [FAIL]
HTTPS (SSL) on port 8443 connection failed. Please check Firewall rules or connection setup.
curl https://api.hiveos.farm:41282                              [FAIL]
HTTPS (SSL) connection on port 41282 failed. Please check Firewall rules or connection setup.
                                                                                                                                       
>>> paris.hiveos.farm
nslookup paris.hiveos.farm                                      [OK]
ping paris.hiveos.farm                                          [OK]
curl http://paris.hiveos.farm                                   [OK]
curl https://paris.hiveos.farm                                  [OK]
                                                                                                                                       
>>> amster.hiveos.farm
nslookup amster.hiveos.farm                                     [OK]
ping amster.hiveos.farm                                         [OK]
curl http://amster.hiveos.farm                                  [OK]
curl https://amster.hiveos.farm                                 [OK]
[email protected]:/hive-config#                                                            

Since the api is not working and paris is, I would like to change that url in rig.conf. However, it gets reverted immediately. Until the problems with api.hiveos.farm are resolved, how can I switch to paris or other working servers?

My rigs are mining but show offline due to this. api server needs to be fixed.
Tagged:

Comments


  • I am having this problem after reinstalling the hive them on a memory card (it was working normally until this morning) is now giving me this message ethminer exited waiting to cool down a bit can someone please help me
  • I finally resolved communication issues with api.hiveos.farm. It was the IPv6 in /etc/hosts because of which the connection to http://api.hiveos.farm was not happening.

    I commented out all the IPv6 stuff and disabled IPv6 on the machine using following commands:
    sysctl -w net.ipv6.conf.all.disable_ipv6=1
    sysctl -w net.ipv6.conf.default.disable_ipv6=1
    
Sign In or Register to comment.