Как подружить 4G модем с HiveOS


#1

Всем привет! Нужна помощь. Не могу подружить 4G модем huawei E3372 с HiveOS. Сам модем прошит HiLink и работает на Windows как модем - подключил и работай. На домашнем компе при запуске HiveOS c флешки этот модем работает прекрасно. Правда в RAS режиме или в NDIS я не в курсе. Но вот на моей ферме не хочет работать. Кстати дисплей подключен в интегрированной видеокарте. Выдает вот такой лог:
curle_couldnt_resolve_host (6) couldn’t resolve host. the given remote host was not resolved.
Не знаю что и делать.


#2

У меня тоже проблема с таким модемом. Запустил на риге hiveos с флешки, модем был подключен, работало все стабильно неделю или две, решил переставить риг, выключил переставил, все… не работает модем, мигает только светодиод. Хотя в Биос определяется. Никакие настройки кроме разгона карт не менял, на других компах модем сразу же начинает работать.


#3

Помогла вот эта статья http://forum.ubuntu.ru/index.php?topic=281443.0


#4

Та же история!
Huawei E3372, прошит HiLink.
При первом подключении определился как ID 12d1:1f01 Huawei Technologies Co., Ltd.
Скачиваем usb_modeswitch .
Пишем usb_modeswitch -c /etc/usb_modeswitch.conf -J, отлично, новый ID 12d1:14dс. Интернет появился.
В файл /etc/usb_modeswitch.conf добавляю строки:
DefaultVendor = 0x12d1
DefaultProduct = 0x1f01
TargetVendor= 0x12d1
TargetProduct= 0x14dс
Перезагрузка, интернета нет!
Достаем модем из USB, вставляем в него же обратно. 30 сек и интернет есть!
Что я сделал неправильно, чтобы модем при загрузке автоматически подключался ?