All rig offline oh Hive, but online in real and work


#1

Anyone have this problem? All rig offline in HiveOs control panel, but they are on and work properly…any solution?


#2

Maybe wrong rig password. What does “hello” command say? Post the answer here.


#3

Yes, i have same problem, but not all time. I think this problem on HiveOs servers not on our rigs.


#4

I’m having the same problem. All my rigs are reporting online but Claymore is reporting offline and I do not get any stats on GPUs in Hive Dashboard. Ethermine shows rigs to be operating normally.


#5

@jameskguen have you changed Claymore remote monitoring port? If you disable remote monitoring the agent that sends data to the hive server is unable to access the miner. If you don’t want remote monitoring to be accessible outside the miner use 127.0.0.1:3333 as monitoring port.


#6

and how do you set it up?


#7

@Teofil I have not changed any settings and every day more and more of my rigs are not reporting Claymore stats.


#8

i have same problem… online on ethermine, but offline in hive stats


#9

same problem, one of my 2 rigs offline but still mining in shellinabox


#10

same problem here… reporting claymore offline, but actually mining on the screen


#11

I am facing same issue…hive is showing offline…but mining is running in background…? what to do…?


#12

i restart rig1, it goes online for around 15min and then offline but still mining :frowning:


#13

This was my problem and my solution in getting my rig back online:

Problem: Single RIG (of three) is always showing OFFLINE but it isn’t

To try and fix this issue I installing the latest HiveOS image 0.5-45. When it started it picked as the default “https://api.hiveos.farm”. It then updated itself to 0.5-46 and asked for Rig number and password. It downloaded the proper configuration and is mining great using XMR-Stak for GPUs and CPUs on nanopool.

With that done I thought that HiveOS (https://the.hiveos.farm/a/profile/rigs) would show that is is back online. But that is not the case it still shows that it is offline. I cleared the browser cache and logged out then back into HiveOS but the offline issue still persists.

The HiveOS Rigs page shows the proper version 0.5-46 (which it had to get from the physical rig) also when the first run was done (Rig number, password) the rig communicated with the hive server to get the proper configuration for XMR-Stak.

So communication is working between the rig and HiveOS servers but the stubborn RED Rig OFFLINE is always present.

Solution:

Problem was finally resolved today.

Running net-test on the rig now does not show https://api.hiveos.farm:41282 at all.

In booting rig it still showed that it was failing to connect to https://api.hiveos.farm:41282.

I then ran firstrun -f and used the default https://api.hiveos.farm.

Rebooting rig now has the problem solved. Rig uses the https://api.hiveos.farm and now shows that it is ONLINE.


#14

thank you, it worked for me as well:)