AMD Driver install

#1

Hi,
I"m having trouble installing the AMD driver 18.50.
I get the following:

The following packages have unmet dependencies:
amdgpu : Depends: amdgpu-lib (= 18.50-725072) but it is not going to be installed
amdgpu-lib32 : Depends: amdgpu-lib (= 18.50-725072) but it is not going to be installed
Depends: libllvm7.0-amdgpu:i386 (= 1:7.0-725072)
Depends: libxatracker2-amdgpu:i386 (= 1:18.2.0-725072)
Depends: libegl1-amdgpu-mesa:i386 (= 1:18.2.0-725072)
Depends: libegl1-amdgpu-mesa-drivers:i386 (= 1:18.2.0-725072)
Depends: libgl1-amdgpu-mesa-glx:i386 (= 1:18.2.0-725072)
Depends: libgl1-amdgpu-mesa-dri:i386 (= 1:18.2.0-725072)
Depends: libosmesa6-amdgpu:i386 (= 1:18.2.0-725072)
Depends: mesa-amdgpu-va-drivers:i386 (= 1:18.2.0-725072)
Depends: mesa-amdgpu-vdpau-drivers:i386 (= 1:18.2.0-725072)
E: Unable to correct problems, you have held broken packages.

I can install 18.10 fine as I believe the missing dependencies are already included.
I have also tried:
sudo dpkg --add-architecture i386
But that doesn’t do anything. Please help.

#2

I was able to resolve it by using the hiveos vega build instead.