Amd-info can't read fan speed

Fan speed was available previously.
I rebooted the worker via the web interface.
After the reboot, the fans are physically spinning fine but amd-info can’t read the fan speed.
Re-booting does not help.

This is with 0.6-138@200510.

Any help is appreciated. Attaching screenshots.

From the dmesg:

15.591095] [drm] Initialized amdgpu 3.33.0 20150101 for 0000:06:00.0 on minor 2
[ 18.621972] amdgpu: [powerplay] pp table size not matched !
[ 18.626813] amdgpu: [powerplay] OD setting (8, 1860) is greater than the maximum allowed (930)
[ 18.626942] amdgpu: [powerplay] OD: Gfxclk: (800, 1780)
[ 18.626943] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.626943] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.626943] amdgpu: [powerplay] OD: Gfx3: (1780, 0)
[ 18.626944] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.626944] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 18.627268] amdgpu: [powerplay] OD: set curve 2: (1500, 3200)
[ 18.627268] amdgpu: [powerplay] OD: Gfxclk: (800, 1500)
[ 18.627269] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.627269] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.627269] amdgpu: [powerplay] OD: Gfx3: (1500, 3200)
[ 18.627270] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.627270] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 18.627283] amdgpu: [powerplay] OD: Gfxclk: (800, 1500)
[ 18.627283] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.627283] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.627284] amdgpu: [powerplay] OD: Gfx3: (1500, 3200)
[ 18.627284] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.627284] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 18.764829] amdgpu: [powerplay] pp table size not matched !
[ 18.768320] amdgpu: [powerplay] OD setting (8, 1860) is greater than the maximum allowed (930)
[ 18.768353] amdgpu: [powerplay] OD: Gfxclk: (800, 1780)
[ 18.768353] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.768354] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.768354] amdgpu: [powerplay] OD: Gfx3: (1780, 0)
[ 18.768354] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.768355] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 18.768918] amdgpu: [powerplay] OD: set curve 2: (1500, 3200)
[ 18.768919] amdgpu: [powerplay] OD: Gfxclk: (800, 1500)
[ 18.768919] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.768919] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.768920] amdgpu: [powerplay] OD: Gfx3: (1500, 3200)
[ 18.768920] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.768920] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 18.768932] amdgpu: [powerplay] OD: Gfxclk: (800, 1500)
[ 18.768932] amdgpu: [powerplay] OD: Gfx1: (800, 0)
[ 18.768932] amdgpu: [powerplay] OD: Gfx2: (1290, 0)
[ 18.768933] amdgpu: [powerplay] OD: Gfx3: (1500, 3200)
[ 18.768933] amdgpu: [powerplay] OD: UclkFmax: 875
[ 18.768933] amdgpu: [powerplay] OD: OverDrivePct: 0
[ 21.059480] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 21.059484] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 21.091458] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 21.091463] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 185.794118] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 185.794122] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 185.834772] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 185.834775] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 313.497884] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 313.497893] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 317.308154] amdgpu: [powerplay] Failed to send message 0xe, response 0xfffffffb, param 0x80
[ 354.137423] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 354.137435] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 356.893463] amdgpu: [powerplay] Failed to send message 0xe, response 0xfffffffb, param 0x80
[ 361.335265] amdgpu: [powerplay] Failed to send message 0x0, response 0xfffffffb
[ 361.335274] amdgpu: [powerplay] Attempt to get current RPM from SMC Failed!
[ 367.751762] amdgpu: [powerplay] Failed to send message 0xe, response 0xfffffffb, param 0x80

It’s a bug of Beta image of non reference Navi cards

1 Like

Beta2


autofan enabled, core voltage and memory clocks unlocked

1 Like

Thanks!!

How do I find Beta2 ? What I saw in the history of releases is only “hiveos-beta-0.6-96@191125.zip”
Is this something I can update from the live installer?

I just enabled autofan.
These are the settings I’ve been running with currently:

Would my hashrate be so much lower just due to the card difference (mine are actually 5600 XTs even though they are shown as 5700s below)? Or are the overclocking/undervolting settings contributing? I played around with the OC settings a bit but it only reduced power draw, never increased hashrate.

Thanks again !

Beta2 currently on internal test only

Your OC settings is wrong

RX 5700 has stock mem clock - 875 MHz (effective - 1750 MHz) and mem max clock 930 MHz
Core clock also set too high and core voltage not set.
If you set to high or too low then driver reset settings and also can causing other problems …

1 Like

Beta2 currently on internal test only

I see. When Beta2 releases, it will fix this bug?
And is the bug only in reading the fan speed status? Or does it have other implications for degraded functionality? For example, controlling the fan.

Your OC settings is wrong

Thanks for the tips! I made some edits to the OC settings and it increased my hashrate by about 2MH. Nice!

if you add core clock (start set from 1200 with step 50 up to 1350) then you can add another 2-3 mh per card. 42-43 mh for 5600 can be achieved

1 Like

this month. don’t have exact ETA
Common bugs fixed and new features implemented

1 Like

if you add core clock (start set from 1200 with step 50 up to 1350) then you can add another 2-3 mh per card. 42-43 mh for 5600 can be achieved

Appreciate the tip! I attempted to do this, but each increment did not change the hashrate. (I rebooted and let it stabalize). I also tried removing the core state setting (separately) in case that was having an effect, but it didn’t change hashrate.
It seems like something else in my settings is blocking that additional 2-3 MH…
I am new to this but it would seem like adjusting the core voltage wouldn’t affect the hashrate but I could be wrong.
And if the mem clock limit is 930 then hmmm…

What miner are you using ?

PhoenixMiner 4.9c
Saw some benchmarks on reddit and this miner was listed as the top performer but I guess that could be outdated. These are my settings:

settings

I saw my records
5600 XT from 41.8 MH/s to 43.2 MH/s at Ethash

I am officially obsessed with reaching that level :slight_smile:
I can’t seem to get above 40.5 MH/s mining ETH with PhoenixMiner.
Played with it some more but >930 mem clock reduces hashrate and no core clock setting gets higher than 40.5 MH/s.
I’m trusting PhoenixMiner’s “autotuning” feature as well. I noticed despite each GPU being the same model, each has a different auto-tuned gt value (8/19/6/7).

Do you know if you were using PhoenixMiner? Maybe I need Beta2 to see those numbers!

I also saw that some folks had flashed the bios of the 5600 XTs to get better performance.
And I do see an option to flash VBIOS via the OC pane in hiveos.
But, I also read that this isn’t always necessary.

Even if I can’t get to 42 MH/s , I am sending you some ETH as a thank you. Appreciate all your help!

Well, I flashed the new beta 2 image. It seems to have created more problems for me than solving any. Now that the fan speed can be read, the fans kick up to like 80% . It doesnt seem to matter if I have autofan enabled or not, or if I use fan% in OC settings. PhoenixMiner 5.0b

My workaround for this issue:

  1. only enable autofan. dont use miner fan settings or OC fan setting
  2. stop miner
  3. start miner

this is required after each boot