AMD Power Draw issues - PLEASE HELP


#1

PLEASE HELP ME!

I have a set of AMD RX570 4GB Pulse gpu’s. Im desperately trying to reduce the power draw of these cards. In Windows the power usage is 90w each but in HiveOS its nearly 140w each! Ive tried everything within HiveOs OC to resolve this issue and its driving me insane!

Several other people have posted the same question within HiveOs discussion boards but I cannot find a straight forward solution to sort this. Theres loads of people online also asking the same question so could anyone please help me and lets make this process easier!!!

I really want to keep this rig on HiveOS. My other rig is Nvidia which works perfectly on HiveOs for low power usage.

  • Please do not say search HiveOS discussion board further - Ive spent 3 days already searching and theres nothing clearly posted on here.
  • Please do not give me this link from Ilya (http://forum.hiveos.farm/profile/Илья) - Its not in English and there is nothing on these pages which clearly explains what to do.

Thanks so much!


#2

Run amdcovc and check if your desired clock speed is greater than the previous one. If it is not - move to a lower DPM/core state.

This will work (DPM 5):
Core clocks: 300 608 910 1077 1145 1150 1236 1290

This will not (DPM 5):
Core clocks: 300 608 910 1077 1155 1150 1236 1290

The solution on the second case would be to select a lower DPM state (#4 in my example):
Core clocks: 300 608 910 1077 1150 1200 1236 1290


#3

Same thing here. Looks like undervolting of AMD cards under linux is not quite supported by drivers. Anyhow, I found helpfull following links:


I’ve taken essential bits from those links and created a script of my own that works for my RX470 cards. Here it is:

for my_coreState in seq ${CORE_STATE[$i]} 7; do
my_args=" --core-state $my_coreState --core-clock ${CORE_CLOCK[$i]} --mem-state $memoryState --mem-clock ${MEM_CLOCK[$i]}"
my_oc_cmd=“wolfamdctrl -i $cardno $my_args”
echo $my_oc_cmd
eval $my_oc_cmd
done

for my_voltState in {1…14}; do
my_args=" --volt-state $givo_voltState --vddc-table-set ${CORE_VDDC[$i]}"
my_oc_cmd=“wolfamdctrl -i $cardno $my_args”
echo $my_oc_cmd
eval $my_oc_cmd
done

For cards with more memory states, expand the range 1…2

I found that this voltage works for me just fine, and there is no additional argument in Dashboard to pass it to the script

for my_memoryState in {1…1}; do
my_args=" --mem-state $my_memoryState --vddci 800"
my_oc_cmd=“wolfamdctrl -i $cardno $my_args”
echo $my_oc_cmd
eval $my_oc_cmd
done

Integrated that script into /hive/sbin/amd-oc (close to the end). So, every time miner start or you change AMD OC settings through Dashboard - this script is executed together with amd-oc script.

There is a problem applying new settings once you run those commands (pp_tables gets locked or something). So, you need to restart the miner every time you change OC settings.

Even though this is not the most perfect solution or the cleanest one - it works for me. Problem is that upgrading of HiveOS overwrites /hive/sbin/amd-oc but I can live with that.

Maybe developers of HiveOS can try and integrate something like this as standard feature - at least untill we get real undervolting support for AMD cards.


#4

The solution on the second case would be to select a lower DPM state (#4 in my example):
Core clocks: 300 608 910 1077 1150 1200 1236 1290

I using same principle and voltage from DPM 3 (65283)


#5

[quote=“giantboy;854”]PLEASE HELP ME!

I have a set of AMD RX570 4GB Pulse gpu’s. Im desperately trying to reduce the power draw of these cards. In Windows the power usage is 90w each but in HiveOS its nearly 140w each! Ive tried everything within HiveOs OC to resolve this issue and its driving me insane!

Several other people have posted the same question within HiveOs discussion boards but I cannot find a straight forward solution to sort this. Theres loads of people online also asking the same question so could anyone please help me and lets make this process easier!!!

I really want to keep this rig on HiveOS. My other rig is Nvidia which works perfectly on HiveOs for low power usage.

  • Please do not say search HiveOS discussion board further - Ive spent 3 days already searching and theres nothing clearly posted on here.
  • Please do not give me this link from Ilya (http://forum.hiveos.farm/profile/Илья) - Its not in English and there is nothing on these pages which clearly explains what to do.

Thanks so much![/quote]


#6

Sorry, I don’t speak English. Easier done than explained.


#7

Send screenshots or scripts of your settings. My cards run at 80-90W on your settings, so you must be doing something else as well. Please share your magic! Explain it in Russian if you have to, we can google translate it.


#8

I really, really appreciate everyones help honestly I do. But Im still none the wiser and don’t speak Russian.


#9

Post screenshot from current settings.