AMD RX570 and NVIDIA 1050ti on the same RIG : what config in xmrstak?

#1

Hi !
Got a Sapphire RX570 nitro+ 4GB (elpida) + a MSI GTX 1050ti (4GB) on my RIG… I’d like to mine CR-v8 coin and decided to tweak those cards a little bit in xmr-stak-fireice-uk-2.5.1
i found a good and stable config for my AMD card but i can not put a config for my NVIDIA card. I must leave the NVIDIA config empty. If not, xmrstak start with an error :
[CUDA] Error gpu 0: </home/user/HaloGenius/xmr-aeon-stak.247/xmrstak/backend/nvidia/nvcc_code/cuda_extra.cu>:360
terminate called after throwing an instance of ‘std::runtime_error’
what(): [CUDA] Error: invalid configuration argument
/hive/xmr-stak/xmr-stak.sh: line 22: 1333 Aborted (core dumped) ./$fork/xmr-stak
xmr-stak exited, waiting to cooldown a bit

How can i “tweak” my 1050ti for better results as it does actually 240 h/s with CR-v8. I had 320 h/s with CR-v7.

Here is my config that leads to the error. Thanx for help !

(PS : you can see indeedminers xmrstak version on the picture but it gives the same result with all xmrstak versions)

#2

Hi,

I use a GPU Gigabyte GTX 1050TI and meka this configurations…

*configs to Nvidia card
“gpu_threads_conf” :
[
{ “index” : 0, “threads” : 17, “blocks” : 60, “bfactor” : 0, “bsleep” : 0,
“affine_to_cpu” : false, “sync_mode” : 3, “mem_mode” : 1,
},
],

This is the result…

Hope this helps.

#3

Well, thank you. But i finally did it like this :

With this config :
“gpu_threads_conf” :
[
// gpu: GeForce GTX 1050 Ti architecture: 61
// memory: 3930/4039 MiB
// smx: 6
{ “index” : 0,
“threads” : 32,
“blocks” : 18,
“bfactor” : 8,
“bsleep” : 100,
“affine_to_cpu” : false,
“sync_mode” : 3,
“mem_mode” : 1,
},