ASIC BETA Questions and Observations


#1

I have started testing the ASIC Beta agent and have a few questions/observations that I’d like some input on or like to share:

  • My first 3 installs went flawlessly. The next 3 installs, also Antminer S9’s, not so much. They continue to mine as expected, but they fail to report to HiveOS as expected. They will send alerts when they go online/offline (telegram) but they show as offline in HiveOS as shown below:

Note it says 5m, it knows when it booted up, so I’m not sure why it isn’t showing as online.

  • After removing and reinstalling the HiveOS agent, AS WELL AS removing the RIG from HIVE, for an S9, you will receive the following :
Error connecting to Hive server https://api.hiveos.farm
/hive/bin/hello: line 98: human-curl-error: command not found
Response body: 
ERROR: no config field in response
Sorry, id and password did not work, check and try again

This can be resolved by manually removing:

./etc/rcS.d/S69hive as well as ./home/root/.profile (ssh in and use rm -rf commands).

  • In theory, should the ASIC agent work on non S9 models? I have an A3 I could test it on if it’s plausible that it will work. I’d rather not try if it’s unlikely to actually work as intended but am happy to if the idea is that the agent should (in theory) work on all (or some) bitmain asics.

  • Feedback: it would be nice if there was a way to filter “monitor” view so you were only seeing asics etc.

  • Feedback: it would be nice if ASIC view did not show the fans tied to a specific hashboard/mining board, however I realize this is also a design issue that will need to be dealt with either way so minor in the big picture.

Thanks for your hard work on this. It’s great to see your product working with ASICs. We had just purchased licenses for AwesomeMiner and ran into so many issues with that product, and I believe yours will be the right fit for our GPU and ASIC miners.


#2

Further troubleshooting on the first issue above:

  • I am unsure what the brown background signifies. I think* that it means that it’s online, but the hive agent isn’t likely communicating with the hive cloud service. But I’m not certain on that. Any clarification would be great.

  • If I type hive into the console, I IMMEDIATELY get a telegram notification saying “%MinerName% booted” but it still shows the same brown background (screenshot above). It does seem to know that the server didn’t reboot however as it continues to track real uptime (which is accurate). I’m unsure if this issue is with the mining agent (perhaps some kind of API access?) or if it’s the hive agent itself.

Thanks in advance!


#3

Took some digging however it seemed that something was hung up. I’d love some context if anyone knows what this is however I went into the /hive/bin folder and ran the “agent” command then noticed it said "There is a screen on: " and it listed an agent as “(Dead ???)”. It gave me an option of wiping using the screen -wipe command and after doing that, the miner IMMEDIATELY came online in the Monitor. I have no idea what Screen or screen -wipe does, but it worked. I performed this command to the other 2 ASICs I have the agent running on, and they came online as well.

Hopefully this helps someone! Still a few outstanding queries from above that I’d love feedback from anyone that knows:

  • What’s the brown background (shown above) signify?

  • What’s screen -wipe actually do?

  • Will this agent (in theory) work on an Antminer A3?


#4

AFAIK work in progress to support Antminer A3, D3, L3


#5

Thanks for the response the other Antminers!

If you’re able to answer any of the other questions above, that’d be great!


#6

I’ve noticed that when power is pulled on the S9’s, the hive agent does not always (or even often) come back to life gracefully.

If you are having this issue, and you have confirmed the S9 is mining (confirmed on the status page), then the following fix will apply:

  1. SSH to the box and navigate to the /hive/bin folder

  2. Execute the agent-screen command. You will likely notice something like this:

agent-screen
There is a screen on:
	30246.agent	(Dead ???)
Remove dead screens with 'screen -wipe'.
There is no screen to be attached matching agent.
  1. Execute the scree -wipe command. This should show you a “(removed)” response (shown below):
screen -wipe
There is a screen on:
	30246.agent	(Removed)
  1. Relaunch the hive agent by issuing the “hive” command.

Everything should come back online. If you’re doing this over and over (as I am when power is cut or the unit is rebooted), you can skip step #2 above.

Does anyone know if there is a perm fix to this or to kill my curiosity, what the screen -wipe, agent-screen etc commands even do? All I know is they fix this problem :slight_smile:


#7

Yes, this is a known issue. Will be fixed on the next update with screen -wipe. For some reason screen sessions are stored not on the real tmpfs.


#8

Do you know when this next update will be? It is frustrating to have to sign in every time it boots to run the screen -wipe command. I am not pushing or impatient, just wondering if you have a time-frame.

Tnx in advance.


#9

Hello,

How do you configure the wallets for antminer S9/L3+?


#10

Добрыйй день, оплатил подписку на месяц на 12 Asic, установил, все было нормально, но заметил такую тенденцию, программа постоянно перезагружает устройства и скидывает частоту на 512, при выставленной 550. Потом прога просто уходит в оффлайн со всеми машинками, хотя они продолжают работать


#11

как настроить кошелек для L3?


#12

OK installed the latest version on L3+ and found a bug. Upon install it removes frequecy settings/card. manually setting it on the asic fixes the speed issue.

Q: is it possible to create an OC profile for the asic?


#13

Hello, i installed the version 0.1-03 on T9+, it works but when i reboot the hive doesnt starts,

[spoiler]Mem: 50476K used, 964948K free, 0K shrd, 837768K buff, 837816K cached
CPU: 9.0% usr 9.0% sys 0.0% nic 81.8% idle 0.0% io 0.0% irq 0.0% sirq
Load average: 0.36 0.30 0.19 1/73 3913
PID PPID USER STAT VSZ %VSZ CPU %CPU COMMAND
1685 1 root S < 165m 16.6 1 4.5 /usr/bin/bmminer --version-file /usr/bin/compile_time --api-listen --default-config /config/bmminer.conf
3815 3811 root R 2836 0.2 0 4.5 top -b -n 1
1426 1 root S 62204 6.1 1 0.0 single-board-test
1430 1 root S 5820 0.5 0 0.0 /usr/bin/monitor-recobtn /usr/bin/factory_config_reset.sh
20004 20000 root S 2840 0.2 1 0.0 {agent} /hive/sbin/bash /hive/bin/agent
1441 1 root S 2840 0.2 0 0.0 /sbin/getty 115200 ttyPS0
1442 1 root S 2840 0.2 1 0.0 /sbin/getty 38400 tty1
1274 1 root S 2836 0.2 1 0.0 /usr/sbin/crond
1443 1 root S 2836 0.2 0 0.0 {monitorcg} /bin/sh /sbin/monitorcg
1620 1 root S 2836 0.2 1 0.0 udhcpc -b -t 10 -A 10 -x hostname antMiner -i eth0
3811 1249 root S 2836 0.2 0 0.0 /bin/sh /www/pages/cgi-bin/monitor.cgi
3816 3811 root S 2836 0.2 0 0.0 /bin/sh /www/pages/cgi-bin/monitor.cgi
1249 1 root S 2776 0.2 0 0.0 /usr/sbin/lighttpd -f /etc/lighttpd.conf
1239 1 avahi S 2736 0.2 1 0.0 avahi-daemon: running [antMiner.local]
614 20004 root S 2704 0.2 0 0.0 sleep 10
1778 1443 root S 2704 0.2 0 0.0 sleep 20m
1240 1239 avahi S 2612 0.2 0 0.0 avahi-daemon: chroot helper
20000 1 root S 2596 0.2 1 0.0 {screen} SCREEN -dm -S agent agent
1227 1 root S 2092 0.2 0 0.0 /usr/sbin/dropbear -r /config/dropbear_rsa_host_key -p 22
1 0 root S 1688 0.1 0 0.0 init [5]
1110 1 root S 1676 0.1 1 0.0 /usr/bin/monitor-ipsig
7 2 root SW 0 0.0 1 0.0 [rcu_preempt]
19 2 root SW 0 0.0 1 0.0 [kworker/u4:1]
3 2 root SW 0 0.0 0 0.0 [ksoftirqd/0]
14 2 root SW 0 0.0 1 0.0 [ksoftirqd/1]
966 2 root SW 0 0.0 0 0.0 [kworker/0:1]
1197 2 root SW 0 0.0 1 0.0 [kworker/1:2]
1080 2 root SW 0 0.0 1 0.0 [ubi_bgt0d]
10 2 root SW 0 0.0 0 0.0 [migration/0]
13 2 root SW 0 0.0 1 0.0 [migration/1]
1082 2 root SW 0 0.0 0 0.0 [ubifs_bgt0_0]
18 2 root SW 0 0.0 1 0.0 [kdevtmpfs]
12160 2 root SW 0 0.0 1 0.0 [kworker/u4:0]
2 0 root SW 0 0.0 0 0.0 [kthreadd]
4 2 root SW 0 0.0 0 0.0 [kworker/0:0]
5 2 root SW< 0 0.0 0 0.0 [kworker/0:0H]
8 2 root SW 0 0.0 0 0.0 [rcu_sched]
9 2 root SW 0 0.0 0 0.0 [rcu_bh]
11 2 root SW 0 0.0 0 0.0 [watchdog/0]
12 2 root SW 0 0.0 1 0.0 [watchdog/1]
16 2 root SW< 0 0.0 1 0.0 [kworker/1:0H]
17 2 root SW< 0 0.0 1 0.0 [khelper]
218 2 root SW< 0 0.0 0 0.0 [writeback]
220 2 root SW< 0 0.0 1 0.0 [bioset]
222 2 root SW< 0 0.0 1 0.0 [kblockd]
238 2 root SW 0 0.0 0 0.0 [khubd]
253 2 root SW< 0 0.0 0 0.0 [edac-poller]
344 2 root SW< 0 0.0 0 0.0 [rpciod]
345 2 root SW 0 0.0 1 0.0 [kworker/1:1]
355 2 root SW 0 0.0 1 0.0 [khungtaskd]
360 2 root SW 0 0.0 0 0.0 [kswapd0]
361 2 root SW 0 0.0 1 0.0 [fsnotify_mark]
362 2 root SW< 0 0.0 1 0.0 [nfsiod]
1004 2 root SW< 0 0.0 1 0.0 [xemacps]
1019 2 root SW< 0 0.0 1 0.0 [kpsmoused]
1075 2 root SW< 0 0.0 1 0.0 [deferwq]
21417 2 root SW 0 0.0 0 0.0 [kworker/u4:2]
[/spoiler]


#14

Any plan for Antminer X3? cryptonight miner requires more changes to miner and pool than any other miner due to hardforks and profit changes. if there’s Hive for X3, I would join for sure.


#15

Also the date and hour doesnt show the actual date, i guess doesnt sync to any server?


#16

Set config override on the web. “bitmain-freq”, “bitmain-fan-ctrl” and other settings.

Can you give me access to ssh on T9+?

Can you give me access to ssh on X3 for test and install hive?


#17

Yes i can give you ssh access but not today, the miner is not in my house, i send you a pm when im there, also i need to open the ports for ssh.


#18

.


#19

Когда сделаете поддержку WhatsMiner M3?


#20

Hello, antminer V9 support?