Asrock h110 pro btc cant disable CSM

Hi
have asrock h110 pro btc motherboard and trying to get working more 9 rx5700xt…
with 9 it works fine but as soon i put on more cards it wont boot… faund solution to disable CSM ant boot only on UEFI… and it works till first rebot from hiveOS… it resets bios again to CSM enabled… and wont boot again…

running from usb stick hiveOS 0.6-164@201003

I have the same issue with my Asrock h110 pro btc mobo. after inputting the 10th GPU on the 10th slot it won’t boot up at all not unless I remove it. Right now, even if I disabled the CSM it won’t boot up anymore.

You have to keep IGPU enabled. When it’s enabled then CSM stays disabled even after reboot and you can run 13 GPUs.

Running 13 GPUs successfully

I made these settings and 10GPU doesn’t start with just 9GPU! Who works above 9GPU could write the BIOS setting? Thanks!

Asrock H110 pro BTC+
sapphire rx 5700 nitro+ 10pcs
POWER 1200W×2

OC Tweaker\Voltage Conf:
PCH VoH: 1200 mV
VCCIO: 1200 mV

Advanced\Chipset Conf:
Above 4GB mmio: Enabled
VT-d: Disabled
All PCIE link speeds: Gen2
All ASPM Supports: Disabled
IOAPIC 24-119: Enabled
IGPU: Enabled
HD Audio: Disbaled
Reset Power Loss: power ON

It’s not an easy handle motherboard and it took for a while for me to understand how to run it with 13 GPU. But once you set it everything correctly it runs quite good and stable.

You have to connect both power inlets (molex powwer sockets on motherboard). Otherwise there will be not enough power to run all 13 PCIE slots.

  • First, Reset BIOS by removing BIOS battery (wait at least 30 seconds)
  • Connect just one GPU to the x16 slot (longest one). Power up (push button on motherboard) and enter BIOS. Modify the values in BIOS as written below:

OC Tweaker\Voltage Conf:
PCH VoH: 1200 mV
VCCIO: 1200 mV

Advanced\Chipset Conf:
Above 4GB mmio: Enabled
VT-d: Disabled
All PCIE link speeds: Gen2
All ASPM Supports: Disabled
IOAPIC 24-119: Enabled
IGPU: Enabled
HD Audio: Disbaled
Reset Power Loss: power ON

-Save and exit BIOS

-Run your rig with only one GPU

  • If everything seems OK (1 GPU is mining) now you can pass to stage for remaining 12 GPUs

-Restart it and enter BIOS. In Boot section disable CSM.
-Save and exit. When rebooted, cut the power before boot! (that’s important!!! -> If you let it boot with 9 or less than 9 GPU, CSM will be enabled automatically and you will not be able to run more than 9 GPU)

-Now connect all GPUs to the remaining x1 slots (short ones). Check that all GPU’s risers and power connections are provided and correct.

-Power on again and suddenly All 13 GPUs should be recognized and work without any problem.

One important point!: If number of connected GPUs drop to below 10, CSM will be enabled automatically and it will not boot. In this case you have to clear BIOS again by removing BIOS battery, wait 30 seconds and start everything from beginning.

And another issue you may encounter.
This motherboard does not boot, if more than 9 GPU connected and if not a monitor is connected!
For any reason, if it’s rebooted while running 9+ GPU, and if there is no monitor connection it stucks and never boot again. Even if later you connect a monitor and restart it. You have to clear BIOS and start everything from scratch again.

I’ve tried many things to solve this problem but no avail.
Finally I found a solution: I bought a cheap monitor for a few dollars (with broken screen)and connected it to GPU0 with a HDMi cable. I keep it on stand-by mode. Now it’s reboot without any problem. When rebooted it sees the standby monitor and boots successfully. Since then I never experienced any boot problem.

It’s stange but works only this way.

Or another way to trick motherboard without monitor: get a DVI dummy plug for a few bucks from Amazon and that will send the same signal as if a monitor is plugged in.