ASUS motherboards not booting, DRAM led red with more than 6 GPUs

Hello everybody.

I have two rigs, both with ASUS mobo (990FX Sabertooth and M5A99X EVO R2.0), pcie bus extended with usual raiser cards. With up to 6 GPUs each they were working fine with HiveOS.

But when I plugged in the 7th GPU things got weird. The motherboards refused to boot, they didn’t complete POST and got stuck with the DRAM led fixed red. The added card works perfectly, I already used it for mining.

So far I tried:

  • restoring previous working configuration
  • removing all but one GPU
  • removing all GPUs
  • removing all DRAM banks
  • inserting one DRAM bank at a time
  • inserting a new DRAM bank
  • changing DRAM slot with single bank or dual banks
  • resetting CMOS by removing battery (unplugged power and waiting)
  • booting pressing the MEMOK button on mobo
  • removing the power button and booting short-circuiting the power pins
  • invoking powers from ancient spirits, calling the stars, dancing around the rig while booting

None of the above had any result in any possible permutation: now I have two working-perfectly-one-moment-ago motherboards apparently fried with that bloody DRAM led fixed red.

How is it possible? Am I the only one on earth who got this? Am I the only one who tried to connect more than 6 graphics cards to a normal motherboard (not mining specific)?

And, most important, can someone help me restoring the motherboards? I cannot believe I fried them just connecting 7 cards, I’m totally sure PSUs are fine (brand new Corsair HX1000i platinum grade), all cards are fine (they were all working correctly with HiveOS).

Thanks in advance for any hints.