ASUS PRIME Z-490-A Motherboard BIOS Settings x6 GPU Help

Hi, hope someone is able to help with this. I have a rig using a ASUS PRIME Z-490-A motherboard. Mining has been working great for about two weeks now with the Linux OS. I currently have x3 Nvidia 1080’s attached to the board via risers. Unfortunately, I have encountered a problem when adding a 4th card. The rig refuses to boot with the 4th card plugged into the board. If I then disconnect the 4th card, no problem, the rig fires up as normal. I have checked all the BIOS settings I can think of for this board, and have made the recommended changes for mining. However, the problem persists. I tried switching PCIe lanes multiple times, but this makes no difference either. 3 cards works, 4, or more cards, no go!

Is there anyone out in the community using this board, or another ASUS PRIME board with the same issue? Have you been able to get 4 or more Nvidia cards running? Please share your fix. I would greatly appreciate it!

check this

I appreciate the reply. Unfortunately my BIOS version is different than the one shown in this video. I have version 2.20.1276. This is the latest right from ASUS.

Also, couple other things:

  1. My mother board is the ASUS PRIME Z490-A (not Z270 shown in the video)
  2. My OS is Linux (not windows)

check BIOS manual.
Try find such things:

  • PCI-E / M.2 slot sharing notice
  • Check 4G Above decoding
  • Try enable CSM support (if it present ob BIOS)
  • Turn off devices that does’t help in mining … e.g. Onboard HD Aduio

Yes sir. All those settings have been made. Works great with X3 GPU, but no boot with X4 GPU.

I think maybe a problem with motherboard like this:

Speed of PCI x16 slots will run at x8 / x8 / x4 but the excess will only run at x1 which causes the issue.

Can anyone confirm for me please, is there a problem trying to run more than X3 GPU with this board?

Thanks for your suggestions so far.

If I had to place a bet, I would say above 4G is not enabled (btw, I’m running 14 cards rigs on this card, so it can do it allright (you just have a boot issue after 10 cards or so, where you need to manually launch))

Yes, I reset and then set this to enabled at least 4 times already. 4G is set in the BIOS.

Are you suggesting that the 4G is not being set on the board, despite it being set in the BIOS?

If you have this same board, then you are using splitters . I’m going to try splitters off the first 3 slots only, and see if that makes a difference.

Thanks for your reply.