Black screen after GRUB selection

After some research, I found out that it is caused by drivers incompatibilities with iGPUs. Is there any way to make it work? I don’t really want to connect the monitor to the GPUs and hinder their mining capabilities.

Here’s some remote commands outputs:

> startx (failed, exitcode=1)
- Fatal server error
(EE) no screens found(EE)

> screen -r (failed, exitcode=1)
Must be connected to a terminal.

Mobo: Asrock B450 Pro4

Primary Video Adaptor is set to IGD on the Bios, also updated Bios to latest (4.50)

CPU: Athlon 3000G

Ok so for some weird reason the monitor is detected if I boot from an SSD… (Transferred OS from flash drive to SSD using the remote console)

Looks like it has something to do with booting on UEFI mode, since booting with the SSD on UEFI mode also bugged the monitor detection

I have the same issue. Did you ever find a fix? I’ve tried swapping boot devices, changing settings, and still got nothin…

Did you change your CSM settings to enable on your mobo? It enables legacy only booting, and I cannot boot HiveOS from my SSD without it. Here’s a video with a demonstration for an Asus Z390-P:

https://www.youtube.com/watch?v=o-tVbdf0CZE

Nowadays I control everything remotely through Hive Shell, you just need to have your rig connected to the internet.

Its way more convenient that way, I don’t even bother connecting a monitor anymore or any peripherals at all. Besides, HiveOS runs more stably with integrated graphics disabled, so its a win either way.