BUG found regarding Litecoinpool username L3+

Couldnt connect to Litepool.
Somehow the . in the username from the pool gets rewritten to a - with %WORKER_NAME% and also with %WORKER_NAME_RAW%

I changed name in Miner now. Sometimes Hive says: “Flight Sheet Config username doesnt match Miner Uername” but he still mines

With Litecoinpool, you have to:

  1. Create an account on Litecoinpool. Recommend using 2FA as well.
  2. Create worker names and worker passwords on Litecoinpool.
  3. You will define your LTC payout address on LitecoinPool. HiveOS wallet is not used.
  4. You will define your payout thresholds on Litecoinpool as well.

HiveOS Flightsheet:
Coin: LTC
Wallet: Sure, use something. But ultimately, what you define on LiteCoinPool willl be used.
Pool: Configure in Miner.
Miner: ASIC Miner.

Setup Miner Config:
Wallet and Worker Template: [USERNAME ON LITECOINPOOL.%WORKER_NAME%]
Pool URL: stratum+tcp://us.litecoinpool.org:3333 … [OR A DIFFERENT URL]
Pass: [WHATEVER YOU DEFINED AS WORKER PASSWORD ON LITECOINPOOL]

Now when your L3+ boots up, you will need to do the following:

  1. Scan your local network, and login to your L3+ from your local network. Use: root/root.
  2. Add your Farm Hash from HiveOS worker settings to your L3+ on local network.
  3. Now your L3+ will show up on HiveOS.
  4. Finally, in HiveOS, go into worker settings and manually re-name your worker to match the worker name already defined on LiteCoinPool.

With Litecoinpool, you have to define your worker names and passwords on the pool FIRST then you adjust HiveOS to follow the naming structure.