Can not connect to the pool. 1st time install

I keep getting the following in the log:

ethminer 0.19.0.2

Build: HiveOS/release/gnu

i 03:57:56 ethminer Configured pool use-eth.hiveon.net : 4444
i 03:57:56 ethminer Api server listening on port 3334.
i 03:57:56 ethminer Selected pool use-eth.hiveon.net : 4444
i 03:57:56 ethminer Negotiation of Eth-Proxy compatible failed. Change your connection parameters
i 03:57:56 ethminer Disconnected from use-eth.hiveon.net:4444
i 03:57:56 ethminer No connection. Suspend mining …
i 03:57:56 ethminer No more connections to try. Exiting…
i 03:57:56 main Got interrupt …
i 03:57:56 ethminer Terminated!

ethminer exited (exitcode=0), waiting to cooldown a bit

Miner screen is running


I tried SSL and not SSL, also usw-eth.
I am stuck.
Any ideas/help?

Edit 1:
ping hiveos.farm
PING hiveos.farm (172.67.28.84) 56(84) bytes of data.
64 bytes from download.hiveos.farm (172.67.28.84): icmp_seq=1 ttl=56 time=33.9 ms
64 bytes from download.hiveos.farm (172.67.28.84): icmp_seq=2 ttl=56 time=20.9 ms

more info from “agent-screen”
Sun Nov 14 14:57:20 EET 2021
Failed to read ethminer stats_raw from localhost:3334
Hashrate ethminer 0 kH/s


curl http://api.hiveos.farm

403 Forbidden

403 Forbidden


openresty/1.19.3.2

Edit 2:


after changing miner from ethminer to phoenixminer:

*** 0:01 *** 11/14 21:37 **************************************
Eth: Mining Unknown on >use-eth.hiveon.net:4444 for 0:00
Eth: Accepted shares 0 (0 stales), rejected shares 0 (0 stales)
Eth: Incorrect shares 0 (0.00%), est. stales percentage 0.00%
Eth: Average speed (5 min): 0.000 MH/s
Eth: Effective speed: 0.00 MH/s; at pool: 0.00 MH/s

GPU1: 34C 0% 10W
GPUs power: 10.5 W
Eth: Connecting to ethash pool use-eth.hiveon.net:4444 (proto: EthProxy)
Eth: Connected to ethash pool use-eth.hiveon.net:4444 (199.127.60.65)
Eth: Connection closed by the pool
Eth: Reconnecting in 5 seconds…
Eth: Connecting to ethash pool use-eth.hiveon.net:4444 (proto: EthProxy)
Eth: Connected to ethash pool use-eth.hiveon.net:4444 (199.127.60.65)
Eth: Connection closed by the pool
Eth: Reconnecting in 5 seconds…