Cannot mine on more than 1 GPU

I haven’t found any solution to my issue thats why I am creating a new topic.

I recently bought a new motherboard and CPU for a mining rig. My problem is that I am only able to mine on one GPU, the 4 other cards are labelled as "GA104 [GeForce RTX 3060 Ti].

If I only plug a single graphic card in a pcie x1 slot, it doesn’t even get recognised.

Motherboard: AsRock H570 Phantom Gaming 4
CPU: Intel Celeron G5905

What I’ve already tried/checked:

  • replace risers
  • use a different pcie slot
  • use a different psu
  • enabling 4G decoding
  • setting Gen1-Gen2-Gen3 speed limit (tried all one by one)
  • disabling csm
  • update drivers
  • downgrade hiveos

If I boot on windows, only one card is correctly working. All others are recognised and showing up in the device manager but with an orange triangle on them.

Note: If I plug each card one by one in the primary x16 pcie slot they all working. If I try to plug them one by one in all other slots, they are not even recognised.

Note2: I also tried using another motherboard (MSI Z370 A-Pro) and all cards get recognised and are all able to mine. I am then expecting a BIOS setting than I am missing or a faulty motherboard

Thanks in advance

Hi,
Your problem is the motherboard… Flash it with the same or newer bios … if does not fix the problem…RIP

I have the same Asrock H570 and also spent a few days to undestand how can I start 4x6600xt.
What I have done:
All PCIE → Gen1
Disabel csm
4g decoding enabled (if it disabled and you insert more than 1 GPU it will be enabled automatically)
disabled SATA controller
and there is also a setting, Ive forgotten the name of it on the screen with PCIE slots and this parameter is right before PCIE Slot settings. It has by default "auto" and Ive changed it on gen1
And after I`ve done it I could see all 4 GPUs , before that only 2 in PCIEx16 slots

Did you manage to start all cards ?

I have plan to build 6x3060Ti rig with additional M.2 USB adapter …