Can't connect throught wifi (802.11n dongle)

Hi everyone.

I’m trying to connect my rig using the 802.11n dongle (this guy) but without success. I’ve read almost every thread in the wi-fi setup (also, usually the 802.11n seems to work) but I was not able to make it work.

The problem is the following:

As soon as I type:

wifi

In my rig’s terminal, I got the following error:

=== WiFi setup ===
Failed to bring up wlan0: SIOCSIFFLAGS: Operation not permitted

wlan0    unassociated ESSID="" Nickname:"<WIFI@REALTEK>"
         Mode: Auto  Frequency=2.412GHz  Access Point: Not-Associated
         Sensitivity:0/0
         Retry:off  RTS the:off  Fragment  the:off
         Encryption key:off
         Power Management:off
         Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0  Missed beacon:0
● 3: wlan0
        Link File: /lib/systemd/network/99-default.link
     Network File: /etc/systemd/network/30-wireless.network
             Type: wlan
            State: off (configuring)
             Path: pci-0000:00:14.0-usb-0:9:1.0
           Driver: r8188eu
           Vendor: Realtek Semiconductor Corp.
            Model: 802.11n
       HW Address: 00:e0:4c:81:88:02 (REALTEK SEMICONDUCTOR CORP.)
...

The wlan0 appears in my iwconfig but not in ifconfig

I’ve already tried to reinstall the r8188eu driver, but with no success.

The same error happens if I try to run:

ifconfig wlan0 up

This is the output of that command:

SIOCSIFFLAGS: Operation not permitted

Also, I’m using HiveOS Beta. (but, I’ve tried and the error persists even in stable)

Any ideas how to fix this?