CN Heavy and XMR stak low hash rates

amd-rx580-rx570-xmrs

#1

I am hardly getting 500-600 hs from my 4 and 8 gb 570s and 580s yet I am constantly on the edge it seems for intensity or clock. What am I doing wrong? I am only getting around 15khs from 24 gpus whereas most friends post 800-1000h/s each (using windows / sbminer). Sample below for 8gb and 4gb rx 580 respectively:

(rx580 8gb 1250/2150): 600-660hs
{ “index” : 1,
“intensity” : 488, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 1,
“intensity” : 488, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
}

(rx580 4gb 1200/2100): 550-620hs
{ “index” : 1,
“intensity” : 448, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 1,
“intensity” : 448, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
}

much more intensity or clock and it starts giving me a cooldown error(even though not hot) or freezing everything up


#2

I’m got around 700-750 H/s on RX 470 equipped with Elpida memory on CN-Heavy
Looks likes too low intensity in your config


#3

have you try to patch the memory with oneclicktiming using Polaris BIOS Editor?
This will give you some more hash but that means you need to mod the BIOS which may break your warranty


#4

Of course I’m using BIOS with patched memory timings.
Also I’ve have different AMD OC profiles for algos - Dagger, CN respectively


#5

Cards are bios flashed and in the 29-31 mh on eth and eth dual mining. It seems to be a linux limitation? Their windows vram/pageF is in the 90gb for 12gpus. Is there a way to do something like this in linux? I was able to tweak maybe 5% more changing clock and memclock speeds, but this seems to be a linux vs windows problem. Most are easily in the 1000s for hashrates on 8gb rx580s and I have 16gb ssds.


#6

Repost from http://forum.hiveos.farm/discussion/390/proshivka-bios-amd/p1

90gb for 12gpus - it’s windows memory manager issue which linux doesn’t have
You can’t start at console custom task manager htop and you will see how small ram linux use and use carefully


#7

pasting this it may help:

on 8gb 4xx/5xx cards …they can more than v7
its crazy
intensity 864 2 threads and im getting 1150 hash lol
and less watts

seems like heavy likes a little less intensity but once found it’s flying


#8

Hi to all! Guys! Tell me please! Whats wrong?

I have ASUS rx470 (570) ME (Samsung) with moded bios. On Ethereum i have around 30 Mh. On CN7-Heavy only 600 H.

I am use this config.

“gpu_threads_conf” : [
// gpu: Ellesmere memory:3130
// compute units: 32
{ “index” : 0,
“intensity” : 800, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
// gpu: Ellesmere memory:3130
// compute units: 32
{ “index” : 1,
“intensity” : 800, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},

and other GPU’s

I tried 2 thread but rig is go offline.

“gpu_threads_conf” : [
// gpu: Ellesmere memory:3130
// compute units: 32
{ “index” : 0,
“intensity” : 800, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
// gpu: Ellesmere memory:3130
// compute units: 32
{ “index” : 0,
“intensity” : 800, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},

Thank you for your advance!


#9

[quote=“pistonbyte;3239”]pasting this it may help:

on 8gb 4xx/5xx cards …they can more than v7
its crazy
intensity 864 2 threads and im getting 1150 hash lol
and less watts

seems like heavy likes a little less intensity but once found it’s flying[/quote]

Is that on a windows or Linux unit? I am incurring crashes and similar if I go too much further on intensity or clock. If I have 120gb ssds will that fix the issue or will it require dual boot os for windows on cn heavy vs linux cn7,cnlite,eth,etc.


#10

Also APA alex… 800 intensity dual channel will be too much.


#11

Did anyone ever figure out how to get more than 700-800 hash dual thread on Linux/HiveOS? In windows I am easily 1050-1150 on all of my RX580 8gb.


#12


#13

It is know fact, that the AMD polaris cards with 8GB memory are performing better on CN-Heavy compared to 4GB models. https://github.com/fireice-uk/xmr-stak/issues/1352

I’m using the following configuration for CN-V7 / CN-Heavy on RX570:

  • CN-V7
    RX570 4G/8G - dual thread, hashrates around 950H/s with core_clock@1175MHz
    (intesity -> start with 1008, lower it by multiple of 8 if You see memory allocation error in xmr-stak/xmrig-amd)
    { “index” : 0, “intensity” : 1000, “worksize” : 8, “strided_index”: 2, “mem_chunk”: 16, “comp_mode”: false, “affine_to_cpu” : false },
    { “index” : 0, “intensity” : 1000, “worksize” : 8, “strided_index”: 2, “mem_chunk”: 16, “comp_mode”: false, “affine_to_cpu” : false },

  • CN-Heavy
    RX570 4G -> single thread, hashrates around 750H/s with core_clock@1175MHz
    [intensity = 8 * (128 - NumOfGPU -1)],
    { “index” : 0, “intensity” : 952, “worksize” : 8, “strided_index”: 2, “mem_chunk”: 16, “comp_mode”: false, “affine_to_cpu” : false },

RX570 8G -> dual thread, hashrates similar to CN-V7
(intesity -> start with 1008, lower it by multiple of 8 if You see memory allocation error in xmr-stak/xmrig-amd)
{ “index” : 0, “intensity” : 1000, “worksize” : 8, “strided_index”: 2, “mem_chunk”: 16, “comp_mode”: false, “affine_to_cpu” : false },
{ “index” : 0, “intensity” : 1000, “worksize” : 8, “strided_index”: 2, “mem_chunk”: 16, “comp_mode”: false, “affine_to_cpu” : false },

Memory strap modification is a MUST!
On 4GB cards, Hynix/Elpidas might perform slightly better then Samsung/Microns because of a more aggressive memory timing.


#14

So, please, help us with yor XMR-STAK settings. Also can answer in russian.