Compiling code and initializing GPUs. This will take a while... and never ends

xmr-stak
cryptonight-heavy
c
#1

xmr-stak 2.4.5
AMD driver 18.10-572953
Same problem https://github.com/fireice-uk/xmr-stak/issues/1659
Config:
[spoiler]
“use_nicehash”: false,
“use_tls”: true,
“tls_fingerprint”: “”,
“pool_weight”: 1,
“rig_id”: “rx5xx_6gpu_rig1”
}
],
“currency”: “haven”,
“call_timeout”: 10,
“retry_time”: 30,
“giveup_limit”: 0,
“verbose_level”: 3,
“print_motd”: true,
“h_print_time”: 60,
“aes_override”: true,
“use_slow_memory”: “warn”,
“tls_secure_algo”: true,
“daemon_mode”: false,
“flush_stdout”: false,
“output_file”: “”,
“httpd_port”: 60045,
“http_login”: “”,
“http_pass”: “”,
“prefer_ipv4”: true,
“use_tls”: “true”

=== /hive/xmr-stak/amd.txt =================================================
“gpu_threads_conf” : [
{ “index” : 0,
“intensity” : 664, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 0,
“intensity” : 664, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 1,
“intensity” : 496, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 1,
“intensity” : 496, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 2,
“intensity” : 864, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
{ “index” : 2,
“intensity” : 864, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true
},
],
“platform_index” : 0,

=== /hive/xmr-stak/nvidia.txt =================================================
“gpu_threads_conf” : [],

=== /hive/xmr-stak/cpu.txt =================================================
“cpu_threads_conf” :
[
{ “low_power_mode” : false, “no_prefetch” : true, “affine_to_cpu” : 0 },

],
[/spoiler]

#2

Did you try to play around with intensity and worksize? Maybe just delete config.txt, remove anything you have withing Config windows in wallet and restart the miner…

So, it will probably try to start single-threaded with some kind of settings… then you can go on and start fine-tuning…

#3

it’s doesn’t help

#4

I’ve updated HiveOS just now from 05.57 to 05.58 to check if this problem is related to xmr-stak or driver version. So, my combination is xmr-stak ver 2.4.5 and amdgpu-pro driver 17.50 - and it is working just fine…

#5

maybe i need downgrade amd driver

#6

Maybe you can try and downgrade HiveOS by:
apt-get install -y --allow-downgrades hive=0.5-57

If that combination isn’t working, then we can be sure that there is some kind of a problem within 18.10 Driver version…

#7

now i’m trying hive=0.5-57, nothing change… i need downgrade driver version

#8

xmr-stak 2.4.5 + driver 18.10 + mixed rig 560D /470 / 570 - works fine

#9

now i’m using hive=0.5-58 and amdgpu-pro driver 17.50, works fine