Disc image file is corrupted

Hi everyone
I’ve been trying to install Hive OS for the whole evening without any success…
Every time I try to mount the image I get the message “The disc image file is corrupted”

So far, I’ve try on 2 different computer, tried to unzip with 7zip .rar and keka, tried the torrent and the 7zip file and tried 2 different mounting method (on USB and virtual mounting). (also tried the beta version for rx5xxx)

Is there something i’m missing, I feel like it’s a pretty easy step haha

Thanks a lot in advance
ATBT

Hi everyone!
So after many trial i’ve finally been able to flash my USB drive.

For anyone who had the same issue, here’s what I did

I don’t know if there was a problem with the zip version but I was only able to do it with the torrent which I cannot give you a reason why.

1.Downloaded from torrent
2.Used 7zip
3.Open Flashing tool with “Run as administrator”

Then I haven’t received the Corrupted file error
I dont know why I was getting this error with the non torrent one.

ATBT