E: Unable to locate package hive-miners-xmrig-new-xmrig

Hi,

After trying the latest upgrade, my XMR miner stopped working:
image

It seems that the upgrade failed as I get the following error when I click on the red message in the screenshot above:

Error installing hive-miners-xmrig-new-xmrig
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package hive-miners-xmrig-new-xmrig

Forced upgrade didn’t help either.

Does anyone have a clue how to fix this?