Error when mining Zcoin, Nvidia driver?

#1

Trying to mine Zcoin with the ccminer mtp fork but i’m getting the following error.

“Unable to query number of CUDA devices! Is an nVidia driver installed?”

Any help would be greatly appriciated.

#2

Check your NVidia driver version. It’s must be 396.xx or higher

#3

Thank you for your response, much appriciated.

Do you know if the “nvidia-driver-update” command will take the driver to that level or do i have to go through the procedure outlined here?

#4

AFAIK Overcooked Panda written this before utility nvidia-driver-update was implemented.

Here is also not bad instruction from Tias

How to update your drivers accordingly

SSH in.

Expand disk [ disk-expand ]
Enable logs [ logs-on ] turn it off again after, if on USB

Reboot: [ sudo reboot ]

Stop hivex [ systemctl stop hivex ]
Stop miner [ miner stop ]

Run [nvidia-driver-update link to Nvidia_driver.run file here] Check here (http://download.hiveos.farm/drivers/) or here (https://www.nvidia.com/Download/Find.aspx?lang=en-us) for the desired driver.

Example: nvidia-driver-update http://us.download.nvidia.com/XFree86/Linux-x86_64/415.27/NVIDIA-Linux-x86_64-415.27.run

Should this fail, it is most likely due to some dependencies still being in use. Reboot the machine, and start again.

Reboot after.

Should you run into any issues after the update (ocs, fans, etc);

Stop hivex [ systemctl stop hivex ]
Stop miner [ miner stop ]
Run [ apt-get install --reinstall -y nvidia-settings ]

Reboot after and try again.

#5

Hello HaloGenius. Just wanted to thank you for your help and how quickly you responded. I really do appriciate because without your help, I would not have been able to update my drivers. Even though i was successful, i was not able to completely follow your instructions. I took a little from you and a little from Overcooked Panda.

In your instructions, the command “systmectl stop hivex”, left me with no command prompt to continue the procedure, also i was not able to specify the driver i wanted to download. So what worked for me was the following.

  1. disk-expand (not sure if this was necessary but i assumed it wouldn’t hurt)
  2. miner stop
  3. killall xinit
  4. nvidia-driver-update
  5. sudo reboot

On one rig, the driver installed failed so i repeated the procedure and it installed sucessfully. All the other rigs updated on the first try.

Thanks for your guidence!