Error when trying to install HiveOS .TAR to Bitmain L3+

Hello, anyone else know why this is happening when I am trying to install HiveOS on my Bitmain Antminer L3+? Here is the error I get when trying to flash.

tar: invalid magic tar: short read

Here is one of my 3 L3+s info does the same thing on all 3, they are all on the same software and hardware

Miner Type Antminer L3+ Blissz v1.02
Hostname antMiner
Model GNU/Linux
Hardware Version 1.0.1.3
Kernel Version Linux 3.8.13 #22 SMP Tue Dec 2 15:26:11 CST 2014
File System Version Sun Jan 14 00:00:57 CST 2018
CGminer Version 4.10.0
Uptime 6
Load Average 1.26, 1.40, 1.29

Miners are working fine on Blissz modded software mining on Litecoinpool and Nicehash.
Thanks in advance. And yes I searched for this error before posting and came up with zero results.