Failed to list opencl devices for platform 0

,

Hey,

I am setting up my first Rig and I’m running into a weird problem where Hive OS is unable to detect my GPU.

The error I get says “failed to list opencl devices for platform 0”.

I have 5700XT strix btw! and gigabyte 5700xt!

See the following image for the exact issue:

I’ve tried upgrading to the beta, as well as trying the stable version. No Idea what’s causing this issue, any help would be appreciated!

Thanks!

UPDATE:

I have spent over 6 hours and various things to fix but no fix yet. Here’s my configuration, perhaps it helps:

Motherboard: Asrock H81 PRO BTC
GPU: AMD RX 5700XT anniversary edition (I have gigabyte, strix, xfx as well but as of now I’m just trying at least one to show up)
GPU is plugged into the 1xPCIe-16 slot directly onto the motherboard. The motherboard has 2 x 4 pin MOLEX that I have directly connected with power from PSU.

The GPU also has some 6x8 pins at the top that I have not connected with anything (I do have the cable and pico board to connect it to, but am I required to connect it? EDIT: I connected them and still no difference)

The lights on the GPU light up tho! Also I couldn’t write config file to the SSD coz I’m on mac and etcher creates NTFS format that mac doesn’t support. So I ended up plugging the SSD directly and it asked for my rid ID and pass and it connected!

I have tried different versions of HiveOS, different cards, different PCIe slots. Nothing seems to be working.

Is there someone who can help me out, I’m so exhausted with this little “side project”.

Thank you!

1 Like

Bumping this, still struggling bad!

same problem !

did you:

  1. set CSM support off in your BIOS (UEFI only)
  2. enable above 4g decoding
  3. set PCIe speeds to gen1 or gen2
  4. enable resize bar support

$ ./amdgpu-pro-install -y --opencl=rocr,legacy

“OpenCL is an optional component of the Pro variant and is installed only if it is specifically requested.”