Fan control does nothing? Cryptonight + RX570

sapphire-pulse-rx-57
xmrstak

#1

Hello there,

I’m mining with 5 RX570s on XMRStak and my fans seem often get stuck at 16% when temps are reaching 75c
I tried changing the fan speed via Tuning, but it doesnt seem to do anything. XMRStak doesnt have fan control, so Im unsure what is preventing proper fan speeds

Thanks in advance


#2

In the lates HiveOS you can create autofan.conf so there will be dynamicall control over fan speed from HiveOS.

Or you can statically set desired fan speed within AMD OC.


#3

[quote=“givo;5225”]In the lates HiveOS you can create autofan.conf so there will be dynamicall control over fan speed from HiveOS.

Or you can statically set desired fan speed within AMD OC.[/quote]
I have it set it in AMD OC and nothing happens

How would i create that autofan.conf file and where should I put it?


#4

It should happen since I am using it that way… Chek /var/log/amd-oc.log to see if AMD OC setting have been applied correctly on all of your cards. If not, try to give them more Core voltage.

Regarding autofan.conf - put it in /hive-config. This is the sample:

Target GPU temp

TARGET_TEMP=50

Minimal fan speed

MIN_FAN=30

Stop mining at critical temp

CRITICAL_TEMP=80

Set to 1 to disable AMD fan control

NO_AMD=0


#5

I also faced to this. NO_AMD = 1 and even stopping the autofan does not help. Fan always stay 22%.


#6

If you set NO_AMD=1, then you need to configure static fan speed in AMD OC.

Sometimes it can happen that one overclocks/undervolts too much and while applying those settings GPU0 hangs and fans stay on low speed.


#7

[quote=“Kedama;1185”]Hello there,

I’m mining with 5 RX570s on XMRStak and my fans seem often get stuck at 16% when temps are reaching 75c
I tried changing the fan speed via Tuning, but it doesnt seem to do anything. XMRStak doesnt have fan control, so Im unsure what is preventing proper fan speeds

Thanks in advance[/quote]

I noticed that if I change OC settings while miner is already running, the volt, clock, & mem settings change but fan gets messed up even with an empty field.

If I restart miner, fans go back to normal. So maybe try restarting miner.

My card bios are all set with target temp of 63, so I disable fan control in claymore and leave fan settings empty in OC. The new autofan.conf doesn’t work for me, so I just let cards use bios settings for best results.