Fan Control/OC on R9 series cards?


#1

Hi all-
HiceOS recognizes my R9 290x GPUs, but does nothing with the fans, even when set to 100%, claymore reports 44% and temps skyrocketing.

How can I (even from command line) kick the fans to 90-100%?


#2

Well, it looks like I may be able to add “-tt -50” to the command line parameters. I’ll try it later.


#3

what version do you have i have r9 380x and h7950 and they are not working on this distribution


#4

Blah. I want to comment on initial thread.


#5

I believe I have the same issue. I managed to get below pasted lines from hive agent when settings are saved and miner is starting. I have no problem setting up RX series but R9s I get following text:

[i]

Wed Feb 14 19:30:52 CET 2018                                                                                                                            
ls: cannot access '/sys/class/drm/card*/device/pp_table': No such file or directory                                                                     
No AMD GPUs found as /sys/class/drm/card*/device/pp_table
With payload                                                                                                                                            
> Sending "danger": Exec failed, exitcode=1

[/i]
If we are accurate I believe OC and fans don’t work at all. Hashrate is what I am used of but thermal management is killing me. Anyone has idea what we should put in the file miner is looking and we can cool our cards.


#6

You can but it doesn’t work. Your card runs at 50% anyway she is above 75°
I doubt is possible to set fans with amdcovs either. :disappointed:


#7

I made a sloppy workaround. I decided to control the fans manually and decided to activate them and give them fixed value in %.

Activating fan 1 by 1!

sudo echo "1" > /sys/class/drm/card[b]0[/b]/device/hwmon/hwmon[b]1[/b]/pwm1_enable
sudo echo "1" > /sys/class/drm/card[b]1[/b]/device/hwmon/hwmon[b]2[/b]/pwm1_enable
sudo echo "1" > /sys/class/drm/card[b]2[/b]/device/hwmon/hwmon[b]3[/b]/pwm1_enable
.
.
.

Manual control works but you don’t need it at all!

sudo echo "75" > /sys/class/drm/card[b]0[/b]/device/hwmon/hwmon[b]1[/b]/pwm1
sudo echo "55" > /sys/class/drm/card[b]1[/b]/device/hwmon/hwmon[b]2[/b]/pwm1
sudo echo "60" > /sys/class/drm/card[b]2[/b]/device/hwmon/hwmon[b]3[/b]/pwm1
.
.
.

Hive & Claymore settings:
-you can adjust cclock and mclock in OC Hive panel. Leave fan bracket empty!
-add to Claymore config override -tt 70 or something that suits you and make lower fan threshold with -fanmin 65,50,70,55.

After activating fans with pwm1_enable I have my R9 Rig cool again. After reboot I needed again to activate fans and they took within 1 minute the settings from Claymore. I hope above helps you too. :slight_smile:


#8

I killed code above when I tried to bold the changes in lines. Again. :expressionless:

sudo echo “1” > /sys/class/drm/card0/device/hwmon/hwmon1/pwm1_enable
sudo echo “1” > /sys/class/drm/card1/device/hwmon/hwmon2/pwm1_enable
sudo echo “1” > /sys/class/drm/card2/device/hwmon/hwmon3/pwm1_enable


#9

with r9 290x works with
sudo echo 1 > /sys/class/drm/card0/device/hwmon/hwmon2/pwm1_enable
sudo echo 200 > /sys/class/drm/card0/device/hwmon/hwmon2/pwm1
verify : with cat everytime, good way, level :wink:
thanks