Fan speed problems

I am not able to get any control of the fan speeds. The autofan settings do absolutely nothing at all. I tried setting phoenixminer to a static %, that also does nothing. I have 3 gpus running 60-70% and overheating; also I have 2 other at 98% fan and way cool. This make no sense at all. No matter what I do or the settings I change they have 0 effect on the fan speed. Why even have this feature if it doesn’t work, can I request you just allow us to set the fan speeds to what we want?

I am very frustrated and desperate at this point and about to ditch hiveos as I can’t have my gpus burning up. Any help is appreciated.