Gigabyte 1660 Super Driver Problem

Hello. I bought new card and tried to install to my new rig. Installed the fresh HiveOS system to my pendrive and start the mining. It is worked but the OS no’t recognize my card correctly and I couldn’t make overlclock (under XServer with nvidia settings panel). Next I tried to update to the newest driver. 440 version. The rig is started, but the OS is stopped the card’s fan to 0%. It almost burned down my card.

Under Windows the Rig is working correctly. (But I hate windows :slight_smile: )

Anyone can mining with Nvidia 1660 Super? What is the correct driver version? Can you help anyone? Thanks!

You can to try running the card in other slots first, and if it doesnt work manually set your PCI-E link speed to Gen2 in your motherboard bios settings and try again, or your motherboard is too old for the 1660ti, or your PCI-E risers too old.

You want version 6c or better. Version 6 kinda sorta works but not really.

If that doesn’t work try to run the card on its own 8 pin rail unshared (the main connector if its has two blocks).

Or just do all of the above and cross your fingers. If it were easy everyone would be doing it.

I use Ver006 Risers. The problem the driver. In the HiveOS is contain old driver to Nvidia. Under Windows the mining is working correctly, but I see other people use 1660 Super under Hiveos. (In Statistics). Have anyone a good configuration or version from HiveOS which is compatible with 1660 Super?

I spent about 8 months troubleshooting the version 6 riser incompatibility. Time to upgrade. I version 6 was old 3 years ago.

If you install the latest HiveOS from the disk image that you download, you’ll have a version of the nvidia driver that is ‘new enough’ to be compatible.

Windows doesn’t work the same way Linux does so you can’t expect the problem to be the same as it would on windows. Linux cares about little things like evenly distributed power across your PCI-X bus. Good luck. If you really want answers you’ll need to provide more information. What motherboard are you using? How are you powering the risers, are you using a breakout board, etc. Also its a very competitive space right now to get the 1660 ti’s working as the cost per watt is the most efficient.

I use HiveOS with more 8xRX580 Rig without problem. I only have a problem with NVidia Rig. This card is new. The latest HiveOS contain the 430.64 Nvidia driver. This is not compatible with 1660Super. The minimum version for this card is: 440.31. I tried to use the Beta HiveOS, this is contain the newer driver for Nvidia.

One card is recoginized. See the picture.

The other 5 card is not recognized correctly. I logged to the rig with SSH and see the “top” usages. The nvidia-smi is use 100% CPU. I don’t know why.

My config is:
Motherboard: Asus Z270-Prime
Memory: 4gb
Pendrive: 16gb
PSU: 1200W ATX Platinum PSU (riser and card directly connected to PSU)

Now I use Windows in this rig, I didn’t modify anything (in bios or hardware), and it is working correctly. I don’t know why don’t work under Linux. :frowning:

If you have one card that is recognized and working the driver loaded properly for that card; it should/would load the exact driver for the rest if no other issues were present.

It doesn’t sound like a driver issue. Check your BIOS settings and probably force ‘gen2’ speed instead of ‘auto.’

I had this problem on a Asus Mining b250 board and fixed it by carefully rearranging the cards one at a time until each one loaded properly (It was having issues with various PCI-X addresses being too close to the previous one for certain slots.) Pay close attention to the card address (01:00.0,03:00.0 etc.) Start with two, then move to three etc.

I googled it and found this https://www.reddit.com/r/gpumining/comments/7i6mhq/asus_prime_z270a_having_instability_issues_need/

They pretty much say the same thing above. Swap riser ports until it works, but ultimately you should upgrade your risers. Thats my two cents. You may spend weeks figuring that out and when you do you’ll have sold your gear. :slight_smile:

Can you send a link from suggested Riser?

Version 6c.