Gigabyte Z390 UD Only 3 GPU accepted

So I’m using a Gigayte mobo and can’t get more than 3 gpu’s. The bios settings are CSM disable, 4G enable, IOAPC 24-119 Entries - Disabled, PCIE Gen 1.
I try with UEFI but it get’s errors and finally just 3 or 2 gpu work. I’m mining RVN with 3070 ti, I have a friend who’s using the same mobo but mining eth with 3080s and does not have my problem.
Any advice?

i want to buy that mobo as well, hoping anyone have an answer too

So I contact Gigabyte and they said thia board is not for mining so is normal I doesn’t detect more than 3 gpus. I’m changing mobo so don’t recommend buying this one.

Is your friend who mines ETH still using the same mb as of now? how many gpu can his board detect?

Upon further research, I notice this board has 3 revisions, 1.0, 1.1 and 2.0 , can you find out what rev is yours and your friend’s ?

Thanks.

I have a similar Board, the Gigabyte Z390 D. 6x AMD W5700 working on it with these settings:

CSM Support: Disabled
VT-d: Disabled
SATA-Controller & OnBoardSound: Disabled (i use a USB-Stick for HiveOS)
PCIe Support: 8/4/4
Above 4G Decoding: Enabled
IOAPIC 24-119 Entries: Disabled (becomes visible if u enable 4G Decoding)
LinkSpeed: Gen1
InitDisplayFirst: IGFX
InternalGraphics: Enabled