GPU power

#1

I have just started mining with HiveOS and still configuring my setup at the moment. Please see attached pic. Does anyone know why is the reported power for GPU#0 is way off? TIA!

#2

unreal numbers usually say that something wrong with bios/hardware setup and causing to variable hashrate on rig

#3

Just switched over from Windows 10. I tried connecting my monitor to the onboard graphics port and later to the 16x PCIe GPU but GPU#0 is still reporting wrong power. Btw, hashrates are absolutely unstable too. In Windows 10, I get a consistently good total hashrate of 366 to 367mh/s for my 12 GPUs before the latest Windows update crashed my rig, that’s why I switched. Do you have any idea what could be the problem? TIA!

#4

Setting PCI-E to gen2 fixed my problem with low hashrate and unreal power draw.

#5

Thanks, brnfex. Just tried but it didn’t help and GPU#0 hashrate is the worst of my 12 GPUs. It fluctuates between 7 to 11 mh/s! The rest are getting better; 29 to 30 mh/s each but occasionally a couple will drop to around 10ish mh/s. https://forum.hiveos.farm/uploads/editor/gh/ibseav7pplmk.jpg

#6

To be fair - I did a few things along with setting pcie to gen2. Wiggled the risers and the small PCIE card, set VT-d to disabled, disable HD audio, set PCIE to gen2. Any of these fixed my issue, but it should be the gen2 setting.
You should also use my undervolt script, by the way. Hive doesn’t set the voltages properly.

#7

LOL! It has been very frustrating for me. I’m not sure if my Asus B250 Mining Expert motherboard has anything to do with it. I just managed to correct GPU#0 power by using another slot but now every single GPU is mining at an incredibly slow 3 to 6 mh/s! LOL!
https://forum.hiveos.farm/uploads/editor/y7/3wcy3mvlwoje.jpg

#8

I just switched the GPU back to the x16 PCIe slot and now it’s back to showing 13982602W!!! But hashrate is back to 29-30mh/s except for GPU#0 mining at around 25mh/s. :s

#9

Tried changing the riser?

#10

Hi all,

Thanks for all your help. :slight_smile:

After several days of trying, I have finally fixed all the issues I have been facing. Now, hashrates are stable and no more weird power usage on GPU#0.

Thought I should share this. For the benefit of all Asus B250 Mining Expert motherboard users, not only must you switch PCIe to gen2 which I did, you have to switch x16 slot PCIe to gen2 as well. <-- I was totally not aware of this earlier because they are on two different pages in the BIOS setup! See below,

Advanced>PCH Configuration>PCI Express Configuration>PCIe Speed>Gen2

Advanced>System Agent (SA) Configuration>PEG Port Configuration>PCIEX16_1 Link Speed>Gen2

Hope this helps some Asus B250 Mining Expert motherboard users. :slight_smile: