GPU Rig stops hashing randomly losing connection must power off/on

I’m about to go nuts. I have my first GPU rig sitting next to my desk. It can run up to 3 days without an issue. Then other times it just randomly stops hashing, the GPU cards go cold over and over. I check it in … Yep, no connectivity. Can’t log into it… I need to power off/on and then it runs fine for a while. No errors… no indicator of what happened or why it dropped connection. I’m trying to mine ETH on Hiveon pool using claymore. I’ve tried various miners like Pheonix, Teamred etc… all with the same problem. It drops about 7 to 10 times a day. I’m almost at my wits’ end. :woozy_face:

Is there a way to diagnose this so I can help prevent it? I’ve read over the forums and couldn’t find anyone else having this exact issue… if they were, there is no solution posted. I’ll need to remote into it.

How can I diagnose? What could it be? This is very frustrating.

Here are my stats:

H310-F PRO (MS-7B25) Micro-Star International Co., Ltd. (2.90 05/25/2020)
CPU 6 × Intel® Core™ i5-9400F CPU @ 2.90GHz AES
Disk Model USB Kingston DataTraveler 2.0 15.5GB

System type
Kernel 5.0.21-200905-hiveos

AOpenCL 19.20
GeForce 210 × 1·RX 570 × 6·RX 590 × 1
80MBPS symmetrical download/upload
Direct connection to the firewall, no rules, completely open - No switch between Firewall and my Rig

AOpenCL 19.20 1·RX 570 × 6·RX 590 × 1
Please see my attached picture.


When you said “it goes cold” do you mean that Hive freezes, e.g., you connect a monitor to your rig and you can see the OS frozen? Or are you implying that you have no monitor connected at all and that a power cycle just fixes the issue?

I’m curious. Are you using a USB drive to load up HiveOS or are you loading HiveOS from a SSD drive? The reason I’m asking is because I currently have an issue on my MSI B360-F Pro Motherboard that runs 8 x 5700 XT cards. Randomly and out of nowhere, either Phoenixminer restarts or the entire rig restarts. Upon booting up again, the Bios screen loads and the rig stays stuck on the Bios screen, not mining anything. Usually upon bootup, you have to hit the DEL key or the F2 or F5 key to load the bios. But in this case, they keyboard is untouched yet the bios screen loads. ARGH.

I have to power down the rig, remove the power cord for a few seconds from the PSU and power the whole thing up again before the rig auto-boots Hive from the USB drive. I did a little reading around and one user said that booting Hive from a SSD should fix the issue. I have a couple of 120GB SSD drives coming and I’ll use BalenaEtcher to put the Hive Beta image onto the SSD drive.

1 Like

I can feel the heat from the cards when the Rig is active. When it stops Hashing the cards go cold. Prompting me to login to HiveOS.Farm… there I see the rig has lost connection.

I know there is a boot to bios feature on these boards. For you, I’d restore it all to defaults with mining enabled and see if it happens again. It may be set to “Boot to BIOS”.

It’s not set to boot to bios. When it boots to bios, it is a random event. Sometimes, the rig boots to bios. Other times, the rig boot from the USB just fine. Between those events, I do not change any settings at all.

After you connect your monitor to your rig (probably connect the monitor to the motherboard graphics port itself – not to any of the mining cards), let me know what you see after your rig goes cold. Obviously, HiveOS or the particular miner in question stops working, but we have not determined if HiveOS stops working because the program itself freezes or if your rig reboots and does not load HiveOS.

I’m not using onboard Video. I’m using a Nvida cheap card plugged into the 16X slot. It allows the screen to show boot up and then it turns blank. no more output from the card. Hence that’s why I was looking for a way to log into it via remote access… I may need to replace the CPU with intel Video to access on-board video.

I used to have USB thumb drive and it did the same thing goes into BIOS when USB not recognized sometimes and it has no where to go BUT BIOS, but now I have M.2 SSD and it works like a charm, always loads the OS.

I have this happen to me but the miner never goes offline. It’s weird. Is it when the miner is mining for dev? You ever solve this issue?


did you fix that issue somehow?
I have exact the same issue with one of my rigs.


1 Like

I’m having the same issue massive chunks of time missing. But mines still using a ton of power but not submitting any shares

takes a manual reset to fix.
Remote restart doesn’t fix it

1 Like

I have the same problem on Asrock H81 for BTC Rev.2, always helps a hard restart. I went to Win 10, but it’s a shame, this soft is on more.

Same thing happening here too.
Times where it stops mining for about 10-30 minutes. Have to restart or wait for it to went past it.
That sucks really!

Has no one an idea what this is ?

Anyone solevd this yet. Having the same issue. I’m using a USB stick for booting

The same issue just started happening to me…any updates?

I had same issue when booting from usb stick. I solved using a SSD drive. Hope that helps.

Same issue for me as well, any solutions?

Same issue - one of my rigs was rock stable for days on end and then all of a sudden (actually after upgrading HiveOS) this started happening. I also boot off the exact same USB stick as the OP @Brinker86 and have the same symptoms as others here. The rig goes “cold” - it is running but the GPU’s are idling and there is nothing on the screen. And of course it always happens just after you have turned out the lights and gone to sleep. and 6 hours later you realised you have lost all that hashing time. Did any of the other members here solve this? @Anthony @Xzandiel @BoostMiner76 @eavmarshall @Beny44 @SaltyEddy @deo @McCownM @pkinopk

Unfortunately not, hopefully keeping this thread alive we can eventually find a solution.

Hi all. I have the same problem. I opened a few days ago this topic, because I thougt it is related to AMD Cards. my topic in AMD section

Normally the problem appears about at 8-10 hours. With LOLminer and keeping all OC`s from all cards exactly the same the rig was running stable for over 30 hours.

Yesterday night 1 o`clock, 1 hour aufter I went to bed it happend again - no hashrate and I lost again the hole night from that rig…

Has anyone solved this issue ?? The same thing is happening to me. I’m using 30 series cards. Z390 A pro motherboard.