GrinGoldMiner

grin
#1

GRIN miner for AMD and Nvidia.

:scream: Attention! Only 8+ GiB devices supported!
Hardware watchdog is strongly recomended.

Version: 2.7b

Usage:
Wallet and worker template: %WAL% or check pool info
Pool URL: Pool URL:port
Pass: Password or check pool info
Extra config arguments: - set your devices config here.


For AMD place this block of text per every GPU and replace the DeviceID number with the corresponding GPU number.

<GPUOption>
  <GPUName>RX580</GPUName>
  <GPUType>AMD</GPUType>
  <DeviceID>0</DeviceID>
  <PlatformID>0</PlatformID>
  <Enabled>true</Enabled>
</GPUOption>


For Nvidia place this block of text per every GPU and replace the DeviceID number with the corresponding GPU number.

<GPUOption>
  <GPUName>GTX1070</GPUName>
  <GPUType>NVIDIA</GPUType>
  <DeviceID>0</DeviceID>
  <PlatformID>0</PlatformID>
  <Enabled>true</Enabled>
</GPUOption>


I will be very grateful for your feedback!

2 Likes
#2

— reserved —

#3

I take it, this isn’t going to work until main-net? Thanks for this post!
Also can we get a cut and paste of the Installation URL?

#4
  1. Currently works on testnet
  2. Yes, it’s proper way - copy-paste URL into “Installation URL” and correct name as “Miner name” appears

Before start mainet some updates, bugs fixes possible.
Stay tuned!

#5

This works. Something to note the “Wallet and worker template” in custom config is:
your_email/rig_name.

This is setup when registering with Sparkpool.

Note that a random email is created when registering, so be sure to add one that you own. HiveOS Wallet address does not really matter unless passing as variable (I didn’t, just hardcoded “your_email/rig_name”).

1 Like
#6

Working fine for me as well, thanks for sharing!

1 Like
#7

I have three GPU, GTX 1060, 1070, 1070ti, only two show up. 1070 ti not recognized. Please help. Thank you.

#8

1060 6G out of memory

#9

Must have 8gb mem to run GRIN.

#11

be sure to use new miner in flightsheet
https://github.com/ATrump/HiveMinersIntegrations/raw/master/gringoldminer-2.6.tar.gz

1 Like
#12

Have notes here on a successful running miner:

http://realworlducs.com/grin-gold-miner-on-hiveos/

1 Like
#13

Now to figure out how to get a wallet address. Looks like no wallet with a gui pre-compiled exists.

#14

Its seems to make sure these new algos are asic resistant you need 6-8gb cards which are making 3-4gb cards useless or unprofitable to mine with

#15

There’s no GUI wallet as of yet, and CLI for Linux or Mac so far, plus there’s not really an address, you can apparently setup a listener node then would have to do a port forward on your network (or a VPS I suppose) and then send to your IP address. There’s alternate methods as well, but I’ve not seen a pool yet implement them.

#16

I’m just wondering - will it be possible to mine Grin with 4GB cards in the near future?

A lot of us have farms with 4-6GB cards (RX470, GTX1060, P104, P106), which were acquired due to their low market prices (when compared to video gaming GPUs).

1 Like
#17

Running numerous rigs in HiveOS, using bminer. Solid hashrate ~4 on each 1070TI. Been running for several hours.

However, sparkpool still shows 0 workers.

Config shows “%40” instead of “@” symbol. Is this normal or problematic?

"-uri cuckaroo29://myactualemailremoved%40gmail.com.miner065@grin-us.sparkpool.com:6666,cuckaroo29://myactualemailremoved%40gmail.com.miner065@grin-us.sparkpool.com:16666 -api 127.0.0.1:1880

#18

Any chance of adding TLS support? Grinmint pool offers a TLS port, but there is no option to enable TLS in the custom miner config. Using a TLS port prevents the miner from running.

1 Like
#19

Can you do one also for Bminer and Gminer please ?

1 Like
#20

Was it tested with RTX GPUs?

#21

Custom was temporary solution. With latest update miner integrated into Hive itself