Hive os and onda x12 motherboard possible issues

So i recently got a https://mineshop.eu/mining-container-minebox/minebox12-all-in-one-12gpu-mining-rig-case/ and i’m having issues with it.
This might have nothing at all with hiveos itself, but i’m posting in case others have had the same problem and possible solution for it.

It’s being very temperamental with hiveos, if i start midnight commander (mc command) and have xwindows started it will immediatedly reboot the rig, kinda annoing since i use mc alot normally. If the problem was only with that command i could live with it but it seems like it randomly hangs/reboots after a while as well when it’s just mining. (tried it with only 1 gfx card that’s known to be good/healthy)
It does this regardless if i have gfx cards installed or not.

I’m not sure if it’s the motherboard itself that’s just trash or something in hiveos, i dont really want to test windows on this rig but i guess i’ll have to soon just to troubleshoot.

Tried to set gen2 on pcie slots in bios, same thing.
I don’t really see anything usefull in the logs, i’ve installed hiveos on a ssd just to be able to see the logs after a reboot.
I guess i’ll send info to mineshop.eu from where i got it, i kinda found a new bios for it but my chineese ain’t that good and i don’t want to blow up the mb.

Got a reply from mineshop.eu where they said “oh, must be the gfx drivers” and nothing more.
Asked them to suggest bios setting and no reply.
Not going to order more from them in the future, that’s for sure.