How can I make HiveOS been working on EFI-GPT?

install
boot
#1

Hi. I can not start the system for 3 days already! When I turn on the CSM to boot into UEFI-GPT, as it should, the system does not boot. 3 days, I just did that, I figured out how to fix it.
As a result, the problem is that HiveOS does not come with an image partition, but with disk image with a ready BIOS-MBR loader. And this is terribly, because it does not allow to use more than 6 cards on my motherboard. Windows, who works at the GPT, quietly sees all 7 cards.
What I did not try to do…

  • I have installed Ubuntu and tried to replace him with HiveOS partition.
  • I have installed WIndows after HiveOS partition.
  • I tried to install the Hive on the GPT disk with the EFI partitioned, but it corrupted it.
  • I was trying to add EFIs before and after the Hive partitons, but it’s very difficult.
  • I tried to use other loaders instead of GRAB.
  • I already learned most of the EFI Shell and Grub shell commands.
    But all in vain. So, is there a simpler solution? I already hate linux, Hive, gParted efi, gDisk, efibootmgr, grub and I’m ready to kill someone!