How do I change the RIG-ID in XMRIG 3.2.0 config.json?

I tried some change methods still doesn’t work …snip_20200306193223

Thank you for your feedback. It’s a bug and will be fixed in next (v0.6-126) version

And also I’m suggest use XMRig (unified) as further development of this miner

1 Like

Thanks to the manager for assistance. I did use XMRig (unified) when mining XMR, but now I want to mine the BBC, but he has to use XMRIG which they modify
I’ll wait for the URL manager to take a look. I have to overwrite this file with the original XMRIG by command mode.
, But I use XMRig (unified) because there is no CN / BBC algorithm in the selection algorithm, so I have to use the old version … This is my current method, and I also hope that the manager can help to solve it this problem‧

XMRIG for BBC

So now I have to update to 200307 to write the rig-id with the machine name?

Is there any way for me to write the rig-id in config.json ?? Because the mining pool I mine has to be used, the machine name must be used to display the machine.

Update to v0.6-126 it’s bring fix to rig-id filed

rig-id filled as %WORKER_NAME% or you can use

"rig-id": "YOUR_WORKER_NAME"

in extra settings

thx~~