How to use Autofan? как использовать Autofan?


#1

i cant figure out how to set it up and launch it, i have no experience with linux and would be very glad if someone could help me.

не могу понять как запустить автофан, с линуксом не работал раньше, буду рад если сможете помочь.


#2

всем привет! я присоединяюсь к вопросу т.к. не совсем понятно как его запустить не из консоли… точнее его и не запустить по другому. и что происходит с настройками которые мы указали в веб интерфейсе ?…
у меня получилось запустить автофан версии 2.4 , но при этом указывая температурные режимы работ я так и не смог добиться устойчивых 55 градусов. Температура на 4-5 градусов выше и ни как ниже не опускается. хотя при 90 % вращения охлаждения она выше 51 не поднимается… в общем в любом случае спасибо за этот инструмент , просто хочется более подробны инструкций ин раша ))))


#3

Решил описать как это делалось у меня :

  • заходим в консоль через putty запускаем MC набрав команду “mc” (без кавычек)
    переходим в каталог /home/user (по умолчанию мы там и находимся)
  • в командную строку снизу копипастом вставляем команду которая загрузит скрипт
    wget -O autofan.sh https://git.io/vhr1n
  • затем там же выполняем команду
    chmod +x autofan.sh
    это пропишет нужные нам права на скрипте для его выполнения
    -и собственно запускаем скрипт
    autofan.sh
    после чего начнется его первичное конфигурирование на подобие вопросов и ответов.

#4

This is not used, there’s an autofan script built into Hive. You just need to create /hive-config/autofan.conf with:

# Target GPU temperature
TARGET_TEMP=60
# Minimal fan speed
MIN_FAN=30
# Stop mining at critical temp
CRITICAL_TEMP=85
# Set to 1 to disable AMD fan control
NO_AMD=0

#5

видимо мы о разных скриптах autofan говорим :slight_smile:
я пользовался вот этим https://github.com/Steambot33/HiveOS-NVIDIA-GPU-autofan-2.0
т.к. он не требует обновления рига (а он у меня не хочет обновляться почему то)


#6

Steambot33’s autofan 2.0 is old and is no longer used. He developed a new version that is already included in the latest Hive releases. You just need to enable it by creating /hive-config/autofan.conf


#7

в том то и дело что не получается обновиться до “latest Hive releases”.
Риг далеко чтобы на него залить новый образ:
Hit:1 http://download.hiveos.farm/repo/binary InRelease
Reading package lists…

Reading package lists…
Building dependency tree…
Reading state information…
Calculating upgrade…
The following packages will be upgraded:
hive
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/42.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database … (Reading database … 5%(Reading database … 10%(Reading database … 15%(Reading database … 20%(Reading database … 25%(Reading database … 30%(Reading database … 35%(Reading database … 40%(Reading database … 45%(Reading database … 50%(Reading database … 55%(Reading database … 60%(Reading database … 65%(Reading database … 70%(Reading database … 75%dpkg: unrecoverable fatal error, aborting:
files list file for package ‘language-pack-gnome-en-base’ is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
Upgrade failed

Update… обновился - теперь Аутофан работает !!!


#8

how do i do that? i dont know how to make files


#9

nano /hive-config/autofan.conf
type the above
ctrl-x, y
restart the rig


#10

Вопрос !? - Риг ночью перегрузился , понять не могу почему. При Этом вроде на пуле этого перезапуска не видно . Но вопрос в том - почему АВТОФАН не стартовал ? есть настройка или где надо прописать в автозагрузку выполнение этого скрипта ?
В целом свою работу скрипт выполняет - еще бы на веб интерфейс вывести его настройку !!!

UPDATE…
с перезагрузкой разобрался, остался вопрос почему автофан не стартанул и мне кажется или он дает нагрузку на проц слегка ?
UPDATE…
по ходу и с автозапуском разобрался … дело в том что у меня остался скрипт autofan 2 от предыдущего автора… и он видимо не давал стартовать встроеному автофану


#11

just going to consolidate what brnfex said along with more info from another thread:

so you gotta modify the autofan config file. mine didn’t even exist, so make one or modifiy with the following contents:

first, SSH in to your rig. The type the following:

nano /hive-config/autofan.conf

then add the following into the file contents:

#https://hiveos.farm/changelog/
REBOOT_ON_ERROR=1

# Target GPU temperature
TARGET_TEMP=60

# Minimal fan speed
MIN_FAN=30

# Stop mining at critical temp
CRITICAL_TEMP=85

# Set to 1 to disable AMD fan control
NO_AMD=1

then type:

Ctrl-x (press ‘y’ to confirm)

Restart the rig.

No new info there, just making things clearer for people searching for the solution.


#12

Can this be used on amd rigs?


#13

Yes. set NO_AMD=0 instead of 1.

But all this is moot as of today with hiveos v2


#14

hi all… i have big problem in my ring…
the ring have restart all the time for this error

i dont have nvndia card… i have amd cards…

error
[/code]
{ “temp” : [ “” ] , “fan” : [ “” ] , “load” : [ “” ] , “power” : [ “” ] , “busids” : [ “” ] , “brand” : [ “” ] }
[/code]

error
>Autofan: GPU temperature 511 is unreal, driver error

**{** **"temp"** **:** **[** "45" **,** "42" **,** "511" **,** "511" **,** "511" **,** "511" ****]**** **,** **"fan"** **:** **[** "0" **,** "0" **,** "0" **,** "0" **,** "0" **,** "0" ****]**** **,** **"load"** **:** **[** "0" **,** "0" **,** "0" **,** "0" **,** "0" **,** "0" ****]**** **,** **"power"** **:** **[** "" **,** "" **,** "" **,** "" **,** "" **,** "" ****]**** **,** **"busids"** **:** **[** "03:00.0" **,** "04:00.0" **,** "08:00.0" **,** "09:00.0" **,** "0c:00.0" **,** "0d:00.0" ****]**** **,** **"brand"** **:** **[** "amd" **,** "amd" **,** "amd" **,** "amd" **,** "amd" **,** "amd" ****]**** ****}****

how to fix error

we try to do what our friend TwoChiefs says

to go here nano /hive-config/autofan.conf

i put here

# Set to 1 to disable AMD fan control
NO_AMD=1

but the error is displayed again and again…
makes a restart ring and stops doing mining
please tell me what I can do