Invalid PCI ROM header signature

#1

i have this message in my rig

[ 53.562558] amdgpu 0000:08:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff

the rig reboot constantly… and the miner send me this message-

:information_source: 12:37:16|cuda-0 | No work. Pause for 3 s.
m 12:37:19|ethminer| not-connected
cl 12:37:19|cl-2 | No work. Pause for 3 s.
cl 12:37:19|cl-1 | No work. Pause for 3 s.
:information_source: 12:37:19|cuda-0 | No work. Pause for 3 s.
cl 12:37:22|cl-2 | No work. Pause for 3 s.
cl 12:37:22|cl-1 | No work. Pause for 3 s.
:information_source: 12:37:22|cuda-0 | No work. Pause for 3 s.
m 12:37:24|ethminer| not-connected

i did that

  1. i reinstalled the hiveos
  2. down the OC settings
  3. change the pci possition.
  4. change 5 times the riser.

any idea?

#2
  1. You trying run ethminer with CUDA support. CUDA - is NVidia technology, youn need OpenCL to run ethminer with AMD GPU’s.
  2. I think this is config problem if you have mixed rig with AMD and Nvidia GPU’s cards
#3

yes, i have, two Nvidia 1060 3G and two Rx 560 AMD…

what specific config i must use?

#4

Due some specific parameters I can’t recommend to use ethminer on mixed rig.
Current version of ethminer better works on NVidia cards from the box
AMD GPU’s works perfectly on Claymore’s Dual and NVidia GPU’s almost the same as on ethminer.

Claymore’s Dual for dividing cards by GPU’s vendor has argument -platform n (n is 1 - use AMD GPUs only. 2 - use NVIDIA GPUs only. 3 - use both AMD and N
VIDIA GPUs. Default value is “3”.)

And for ethminer use button in Wallet config.

On mixed rig my choose is Claymore’s Dual ETH GPU Miner