Manually update Nvidia driver to 396.18


#1

I’ve downloaded NVIDIA-Linux_x86_x64_396.18.run file and saved it to /hive-drivers-pack . I chmod it and after I run it I get the following error : ----------------------------------------- Extraction failed ; Cleaning up. I tried with giving it tmpdir for extraction but nothing works.I read in nvidia forums that this is mainly a problem with not enough space on USB/HDD i am using 16 GB USB 3.0 which should have plenty of space . in MC i get to see that in most folders I have only used about 28 % of space so should be available at least 4-5 gb more. Please help solve this problem !!!


#2

HiveOS filesystem only 8Gb total. If want to use all space youn need to repartition drive.

R396 series is developer version. I don’t know why do you need it

If you installed HiveOS from image v0.5-45 first of all you need to execute command
logs-on then reboot and then you can try to install NVidia driver


#3

At the moment there are a few miners, which require cuda 9.2/396.xx driver. Any plans to install the driver?

I tried to install it. The problem that nvidia-settings core dumps always.
I know that it works on usual linux distros.


#4

You can do the following to enable a temp directory with more freespace, however, be warned that installing the 396 drivers broke my ability to control fans, oc, and power levels.

export TMPDIR=/path/to/dir/with/freespace

so you would login via ssh, then run the above command to temporarily set the tmpdir variable (for that session only) and then you are able to execute the driver .run file.


#5

These are the steps that work for me and not all may be necessary, but it works for me everytime.

##are comments.

##Wait for miner to start before continuing, run all from putty, ssh, shellinabox, at the PC etc… run the following commands. Replace the nvidia link with the version you want to install.

logs-on
reboot

##after reboot wait for miner to start

miner stop
killall xinit
sudo su
sudo init 3
cd /hive-drivers-pack/
wget http://us.download.nvidia.com/XFree86/Linux-x86_64/390.77/NVIDIA-Linux-x86_64-390.77.run
chmod +x /hive-drivers-pack/NVIDIA-Linux-x86_64-390.77.run
sudo sh /hive-drivers-pack/NVIDIA-Linux-x86_64-390.77.run
##Select yes to DKMS and Yes to 32bit libraries
##Select Yes to run nvidia x config
logs-off
reboot


#6

doesn’t work for me with usb stick ;(