Miscellaneous crashes, can't get over 24hr uptime

I’m seeing my rig crash either on:

  1. “Starting daily apt activities”
  2. “CPU #3 stuck!”
  3. BASH won’t respond, gives no evidence.

I had better stability (still not perfect) when I was using just ethminer, but since the ETH DAG went over 4GB I’ve switched my two 4GB cards to ETC using lolminer.

I checked the root crontab to see if I could temporarily turn off the “daily apt activities” but didn’t see anything in there regarding apt.

Anyone have an idea how I can check logs (pre-reboot) or further diagnose this problem? It’s gotten so annoying that I’m considering switching to plain Linux, Ubuntu server or something.

Sounds like a bad riser card/cards to me bro

Well thanks for the suggestion, I think I fixed it. Currently at 2d uptime. Miners stalled a couple times but I could restart them remotely via software.

Dicked around with plain Windows, Ubuntu, and other mining OSes… came back to Hive because it’s a good mix of user-friendliness and power/flexibility.

Ended up replacing thermal paste on the CPU and a couple of cards, and reflashing all of them (via bootable DOS & amdflash.exe) to stock BIOS. Lost a couple MH/s but that’s nothing compared to the convenience of stability.

So if anyone’s having a similar problem, take a step back, do a rebuild. Reformat your SD card, replace thermal paste, check risers, BIOS, all of it. Even if each step doesn’t address the problem, you might stumble upon something that works.