My RX 580 8GB (Red Dragon) Won't Overclocking

Hi, so I just bought 2 more cards recently to add to my rig but I can’t seem to get it to overclocking in HiveOS.
The 2 cards is the
PowerColor Radeon RX 580 8GB GDDR5 Graphics Card (AXRX5808GBD53DHDV2OC)

The rest of my cards are the Red Devil version… Idk if it had been bios mod b4 I bought them but I can get an average of 32.5Mh/s for them running PheonixMiner with just switching to Compute Mode in AMD Driver.
But this Red Dragon version just won’t budge an inch no matter what setting I had… so I try to Flash VBIOS using a file I downloaded from TechPowerUp Bios Collection but I guess that’s just the default bios since it doesn’t work still… So if any of you have a MODed file of this Red Dragon model, then please help a fellow brother out, huh?

EDIT: Also if any of you guys have a better setting for the [Red Devil’s Samsung K4G80325FB · 113-C9403100_101] then please also share them… I can’t seem to get them to go past 30Mh/s.

Hi,
Did you find a solution for your problem? I also have a red dragon 8GB and with the original bios i can reach 25Mh but no more…
I have a mod bios which is supposed to reach 30-31mh but when I flash my card with this bios hiveos (with lolminer) does not mine at all. The card is well recognized in windows and in Hiveos but it does not mine… I don’t understand why.
If you want I can send you this bios and you could try it?

Couldn’t really find a solution, so I just bios modded it and flash it on HiveOS and it give me 30 Mh/s without touching any of the setting.