NBMiner parameter lhr-reduce-value not working in HiveOS

Using the latest NBMiner 40.1, when I set the parameter (“lhr-reduce-value”: “0.1”) it doesn’t work. It actually freezes the lhr value at 74 even when it unlocks. I tried the value without quotes but HiveOS doesn’t except that, it has to be in double-quotes.

I saw a ticket on github and it says the problem may lie in HiveOS. I have the link to the NBMiner github issue below.

Can someone take at this?

For one, you should be using T-Rex right now, I went from 423-431(mostly 424) to 430-440(mostly 433.5) switching from NB to Trex.
But what I used/have in my NB flightsheet is:

“lhr”:“75,75,75”
“lhr-reduce-time”: 5
“lhr-reduce-value”: “0.4”

Which I copied from an offtopic post here. It apparently locks lhr at 75% (as in NB doesn’t reduce the %) and I adjusted the tune until each of the 3 gpus no longer triggered lhr.

T-Rex over time adjust lhr % on it’s on, both up and down. It has most of my gpus on 75%. Best I ever got out of my 2 evga xc3 3070 tis was 58mh, they now run at 61+mh.

I have evaluated T-rex and yes it does give me about 9-10 more MH/s. What I have found is that T-rex also uses more wattage per card (about 20 W per card) which causes the cards to run hotter than NBMiner. So I’m choosing to sacrifice 9-10MH/s for less overall wattage consumption and less temp. Running my rig at 1.23 GH/s, then 10MH/s is negligible. I have also seen overall, NBMiner gives me more shares per minute than T-rex which is a major plus.

Yeah I know I can adjust the tuning but I wanted NBMiner to do it without having to manually do it. Maybe after it has run for over 48 hrs straight, I could manually insert the values. But why are you using this parameter (“lhr-reduce-value”: “0.4”), if the values are locked at 75. It will never reduce the values, so that parameter is not needed, unless I’m missing something on how it works?

I’m not seeing that at all, the wattage increase I mean. But I am using almost entirely lhr gpus with core clocks locked.

I honestly just copied that command from a off topic post in another thread, and I’ve only glanced at the wikis on this stuff, so I don’t pretend to know exactly what it’s doing. But the end result is it holding lhr at 75%, because NO it will not stay locked at 75 with just the command “lhr”: “75”. At least not on my rigs.

The only thing I know is that Trex added 1-3 mh to my evga ftw3 3080ti, and zero to my evga xc3 3080ti. And about 1+ to my asus prebuilt 3060s, but the always troublesome gigabyte 3060ti remains unchanged, if not a bit lower. The 2 evga xc3 3070tis went from 57’ish to solid 60.5-61+. All with no tuning changes and cores locked. Takes it about 15 minutes to start adjusting, but it jacks almost everything to 75%, with the exception of the xc3 3080ti down to 72-73%, and the 3060ti to 74.5%.

Here’s the pic I got the arguments from, can’t remember the post.