Need help with miner automatically changing


#1

hi i am using claymore-x to mine xmr but my rig is automatically changing to claymore to mine eth , even though there is no eth address in that wallet. I am on a public net but i already followed security measures to disable ssh and shellinabox. I wonder how i can stop this, thanks !!


#2

Hi. I’m also having the same problem with HiveOS Version:0.5-47. I don’t know if is there any relation, but this behavior started after some tests with the WatchDog configuration.
I’m not even using Claymore. I’m using ccminer and after some time, ccminer is gone and claymore is running making me loose money, because I’m using Power and not getting any return.


#3

Hi. I’m also having the same problem with HiveOS Version:0.5-47. I don’t know if is there any relation, but this behavior started after some tests with the WatchDog configuration.
I’m not even using Claymore. I’m using ccminer and after some time, ccminer is gone and claymore is running making me loose money, because I’m using Power and not getting any return.


#4

Hi. I downgraded to ver =0.5-45 and it works fine now again.


#5

Hi again. Downgrading didn’t solve the problem. The “bug” takes more time to show, but after 2 days I get claymore again running instead of “my ccminer”. I think this is a bug related to Watchdog configurations because besides I have only CCMINER running, CLAYMORE restarts my rig because of a GPU hanging. What the hell? Why is CLAYMORE checking my GPU state if it is not running?
Hi guys, could you please try to fix this bug. It makes us loose money and we have to be always checking the rigs to know if they are using the miner we configured or… CLAYMORE.


#6

dd


#7

same thing here.
From time-to-time current miner (ccminer or whatever) stops and claymore starts automatically. i looked at the log and noticed that somehow the pool, address and email have been changed to someones else’s address. That means calymore has been hijacked using the port 3333.
It could be your case also.

so my question is how to block these attacks and how to change the remote port or how to disable claymore completely?


#8

In “/hive” there are Claymore (and other miners) sub-folders so you can remove / rename them if you want. But, if your system is hacked, then I don’t think this will solve your problem.

First, change password on your rig.

Then, try checking logins by executing “last” and “lastb” to see if you can see some unknown logins. Close all access to the rig from the public Internet. Also, try using “netstat” to see if there are some strange connections and open ports that should not be opened…


#9

Hi.
But is this a CLAYMORE problem or a HIVEOS bug?
If I’m not using CLAYMORE, and I don’t have CLAYMORE configured to run, no CLAYMPRE in any wallet, it shouldn’t be running and so, it shouldn’t be able to “do nothing”.
Isn’t it HIVEOS that starts the miners?
Is CLAYMORE running without being started by HIVEOS?