New AMDGPU-PRO driver Causes Poor Cryptonight Heavy Performance

gpu-driver

#1

I was running a RX 580 8G rig mining loki for roughly 1000h/s per card, my usb stick gave up the other day so I flashed a new one with the latest image only to found out the latest version of hiveos loaded with version 18 of AMDGPU-PRO driver was only hashing 800h/s on the same card with the same oc settings. After flashing it with version 0.5-32 IMAGE RELEASE with AMDGPU-PRO driver 17.50, I am running 1000h/s per card again. Is there going to be a option to choose driver version in the future release?


#2

you could change drive:

https://forum.hiveos.farm/discussion/17/driver-reinstall


#3

what settings do you have for 1kh / s? I can not go over 700 :frowning:


#4

I tried downgrading the driver at first but I got some kind of opencl error, so I just flashed an older version of hiveos instead.
I’m running Sapphire Nitro+ Special Edition RX 580 8G (Micron memory) with one click timing bios mod, OC settings is 1150/2200。xmr-stak fireice fork with 2 threads settings like below:
“intensity” : 1000, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true


#5

maybe you’re using 0.5-52 - this have new drivers, but bug for OC

ok thx guy :slight_smile: I’ll check for me:)


#6

I tried downgrading the driver at first but I got some kind of opencl error, so I just flashed an older version of hiveos instead.
I’m running Sapphire Nitro+ Special Edition RX 580 8G (Micron memory) with one click timing bios mod, OC settings is 1150/2200。xmr-stak fireice fork with 2 threads settings like below:
“intensity” : 1000, “worksize” : 8,
“affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 2,
“comp_mode” : true[/quote]

Please can you share configuration for 2 thread?


#7

Two threads - repeat the config. Two configs for each index. It’s not harder than that. :smiley:


#8

Thank you, got it!