No GUI, only command line?

#1

Hi, I’ve installed hiveOS but there is no GUI for me. My rig loads into the agent-screen and does its initialization. I can detach from the screen, and move through them, as if I was on a command line distro.

The “exit” command leaves me hanging as there is no terminal to write to and I have to reset the rig. What gui is hiveOS using? Any help would be appreciated.

Thanks

#2

Was using integrated graphics. Server X would not load at start up when amd drivers were installed with iGPU.
Disabling iGPU in the BIOS and connecting the display to the card connected at the16x port, solved the problem.

#3

Is there a way to use this OS without having a GPU connected to the 16x? I don’t have room to add a GPU directly to the motherboard. Its a bad design but it’s what I have to work with. Can I configure the system to use the GUI from a 1x riser GPU?

#4

X server needs only for NVidia GPU because without it overclocking not working.
If your rig has NVidia cards you must connect one of them to X16 slot.

If you have AMD based rig you don’t need X server.

If you want to have nice pictures you can go M$ WindowZ :stuck_out_tongue:

#5

Well said. I’m all AMD so I will try it out. Currently, Windows miner but looking for something more stable. Hope this is the answer. Thank you!

#6

FYI - I have my Nvidia GPU connected to the 16x via 1x riser and boots up into the GUI without issue.

A little slow if trying to load anything other than terminal windows but works enough for me.