Not enough memory / DAG file / OpenCL error / issues AMD RX570/RX580 4GB

#1

I have a AMD rig running AMD RX570 and RX580 cards all 4GB.
I have been mining ETC for months with no issues using Claymore. Out of the blue its stopped working and is now showing the following issues.

Not enough GPU memory to place DAG.
OpenCL error issues
All cards fail not just one

I know this is a 4GB memory issue and I would normally resolve it by putting the following in the .bat file:
setx GPU_FORCE_64BIT_PTR 0
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_SINGLE_ALLOC_PERCENT 100

BUT Im unsure how to resolve this using Hive.

If I change Claymore to mine ETH it works fine.
If I change to mine ETC using Bminer or Phoenixminer it mines ETC fine.

It just seems to be ETC Claymore issue.

Any thoughts?

Thanks

1 Like
#2

Hi, now times i have the same problem… and on the same card (4gb)
I can not mine ETH and ETC, but with any another Dagger-Hashimoto algo works good.

P.s. You should try to change miner to Ethminer (on my rig its work).

If anyone have ideas, please…)

1 Like
#3

Two days ago I have to rebuild couple of my RX584 rigs, update Hive version to 0.6-56, and got the same shit problem on ETH claymore. Other rigs perfectly works on 0.5-82 version all year…

Read your topic and change miner to phoenixminer, it hasn’t such problem, but appears some slate shares… Need solvation with claymore. Or just have to rollback all rigs to 0.5-82?

1 Like
#4

Hey there thanks for your reply appreciate it. Ethminer and Pheonix will mine ETC fine but I can’t get the same hashrate and they use more power as Claymore. ETH is more profitable at the moment and hashes and fine with Claymore so I’m sticking to that now thankfully. I’ll try downgrading hiveos and see if that works. All the best.

#5

Downgrading doesn’t resolve the issue which sucks hehehe. So bizarre… Not sure if its a virtual memory issue being that there isn’t enough space for the DAG. Don’t know how to sort that on hive though. So weird that ETH but ETC isn’t on Claymore. Ill have to have more of a go with Phoenix miner.

#6

When you use Phoenix miner do you set your overclock / undervolt settings any differently to Claymore?

#7

I have a solution for Claymore.
Go to your RIG Settings and DISABLE the GUI interface.

My Rigs working good…)

2 Likes
#8

Hey its works!!! Yaaaaaaaaaaaaaayasssss!

#9

Thanks so so much for your help, thanks goodness this works! Excellent!

#10

Okay I moved over from ETH to ETC on Claymore this morning. It mined fine for 5 hours perfectly and its now throwing the same DAG errors! So annoying. Ah well!

#11

same problem

#12

Rx 570 4g dag file not enough. Time to change gpu?

#13

I off gui , no result. Change miner from 14.7 to 22.0, no result . I almost inlove hive.

1 Like
#14

Sorry from 14.7 to 12.0

1 Like
#15

I’m just keeping to Eth for now, it works fine on Claymore. Disabling Gui in settings did work at first,. I thought we had it cracked heheh!

#16

I have the same problem since the dag file went to #280. My friend aswell. Now mining ETH but it is a weird problem.

1 Like
#17

I have the same problem. It doesnt affect all of my RX 470-4GB cards. Just some cards…any reason why? Disabling GUI doesnt work for me.

1 Like
#18

For me it’s all cards 470/570/580. And also disabeling gui does not work.

1 Like
#19

Does Hive developer knows about it? I see that there is another thread in Russian where some users are complaining that they have the same issue.

1 Like
#20

Idk how can we let them know?