OhMyGod Pill not working for me, help! - Asus Geforce GTX 1080 ti Turbo 11GB

I purchased a used Asus Geforce GTX 1080 ti Turbo 11GB card yesterday and the reason i did so was for the boost provided by the pill. No matter what i do, i cannot get it get anywhere near 50MH/s. On some occasions ticking the pill setting in the OC makes the hash rate go down. I’ve tried copying OC settings in other posts and nothing works. I can actually get the card to go to 43 MH/s using 110 on the core clock and -700 on the memory and the pill seems to be increasing the rate, but other people are setting way different OCs in the plus range and getting 50 MH/s plus. What am i doing wrong?? I need to get this working, otherwise my ROI is blasted. Please help!! To be honest, i’m not even sure the pill is working, when i turn it off the hash rate stays the same.

I am also struggling to understand how the PILL works on my 1080Ti.

There are no predictable trends that this card would follow when increasing or decreasing any of the parameters. For example power limit 120W used to give me 45MHS, while 130W gave me around 24.

I have spent hours basically guessing (starting from a certain value and using increments) and came to 47MHS. I cannot understand what is causing this card not to go above.

Sometimes when experimenting, going back to some initial value would give a massively different result (sometimes better sometimes worse?!).

I am stuck around 47.5 MHS because I’m tired of constantly rebooting and fiddling around with it.
Maybe you can use those settings for your card too.