Only invalid shares with same settings

Hi,

Im new to to mining and I started just three days ago. I got my RIG setup with two RTX 3070 and everything worked fine in the beginning. The next day I wanted to adjust the overclocking settings and i found that -100 CC 2800MC and 130W the best setting was. I tried to get more out of the GPUs but after realisier that they have hit their limit I only got invalid shares. Changing the algorithm from ETHash helped me get valid shares again but the amount of invalid shares is way to much. I even changed the settings from 2800MC to 1800 and it still doesn’t help. How can I get back to those large numbers with ETHash?