Overclock settings not applying on 0.5-51


#1

Running a fresh image, tried on 2 different 8 GPU rigs. Only overclock setting that appears to be applying is the power. Memory and fan settings not applying, although they appear to be registering. My fans seem to be set to auto, and memory is not affected. This used to work perfectly fine on previous builds.

I’ve tried this on both EVGA and Founders edition 8 GPU rigs.

I have even tried building a new OC profile - same results.

Tue May 15 11:39:49 EDT 2018

Detected 8 NVIDIA cards
CLOCK = -20 -50 -30 -30 -30 -30 -20 -20
MEM = 1420 1440 1440 1420 1440 1440 1440 1440
FAN = 55 60 60 60 55 60 65 65
PLIMIT = 99 99 99 99 99 99 99 99

nvidia-persistenced failed to initialize. Check syslog for more details.
Persistence mode is already Enabled for GPU 00000000:01:00.0.
Persistence mode is already Enabled for GPU 00000000:02:00.0.
Persistence mode is already Enabled for GPU 00000000:03:00.0.
Persistence mode is already Enabled for GPU 00000000:04:00.0.
Persistence mode is already Enabled for GPU 00000000:05:00.0.
Persistence mode is already Enabled for GPU 00000000:07:00.0.
Persistence mode is already Enabled for GPU 00000000:08:00.0.
Persistence mode is already Enabled for GPU 00000000:09:00.0.
All done.

=== GPU 0, 01:00.0 GeForce GTX 1070, 98.14 W / 99.00 W (Default 151.00 W) === 11:39:49
Power limit for GPU 00000000:01:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 1, 02:00.0 GeForce GTX 1070, 97.93 W / 99.00 W (Default 151.00 W) === 11:39:49
Power limit for GPU 00000000:02:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 2, 03:00.0 GeForce GTX 1070, 100.02 W / 99.00 W (Default 151.00 W) === 11:39:49
Power limit for GPU 00000000:03:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 3, 04:00.0 GeForce GTX 1070, 99.09 W / 99.00 W (Default 151.00 W) === 11:39:49
Power limit for GPU 00000000:04:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 4, 05:00.0 GeForce GTX 1070, 96.10 W / 99.00 W (Default 151.00 W) === 11:39:50
Power limit for GPU 00000000:05:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 5, 07:00.0 GeForce GTX 1070, 97.31 W / 99.00 W (Default 151.00 W) === 11:39:50
Power limit for GPU 00000000:07:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 6, 08:00.0 GeForce GTX 1070, 99.89 W / 99.00 W (Default 151.00 W) === 11:39:50
Power limit for GPU 00000000:08:00.0 was set to 99.00 W from 99.00 W.
All done.

=== GPU 7, 09:00.0 GeForce GTX 1070, 98.14 W / 99.00 W (Default 151.00 W) === 11:39:50
Power limit for GPU 00000000:09:00.0 was set to 99.00 W from 99.00 W.
All done.


#2

Same for me - on latest image. Will go back to old one until it’s fixed.

Tue May 15 18:03:22 BST 2018

Detected 10 NVIDIA cards
CLOCK = 150 150 150 150 150 150 150 150 150 150
MEM = -503 -503 -503 -503 -503 -503 -503 -503 -503 -503
FAN = 45 45 45 45 45 45 45 45 45 45
PLIMIT = 126 126 126 126 126 126 126 126 126 126

Persistence mode is already Enabled for GPU 00000000:01:00.0.
Persistence mode is already Enabled for GPU 00000000:04:00.0.
Persistence mode is already Enabled for GPU 00000000:06:00.0.
Persistence mode is already Enabled for GPU 00000000:09:00.0.
Persistence mode is already Enabled for GPU 00000000:0A:00.0.
Persistence mode is already Enabled for GPU 00000000:0B:00.0.
Persistence mode is already Enabled for GPU 00000000:0C:00.0.
Persistence mode is already Enabled for GPU 00000000:0D:00.0.
Persistence mode is already Enabled for GPU 00000000:0E:00.0.
Persistence mode is already Enabled for GPU 00000000:0F:00.0.
All done.

=== GPU 0, 01:00.0 GeForce GTX 1070 Ti, 9.34 W / 180.00 W (Default 180.00 W) === 18:03:22
Power limit for GPU 00000000:01:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 1, 04:00.0 GeForce GTX 1070 Ti, 6.45 W / 180.00 W (Default 180.00 W) === 18:03:23
Power limit for GPU 00000000:04:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 2, 06:00.0 GeForce GTX 1070 Ti, 6.16 W / 180.00 W (Default 180.00 W) === 18:03:23
Power limit for GPU 00000000:06:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 3, 09:00.0 GeForce GTX 1070 Ti, 11.42 W / 180.00 W (Default 180.00 W) === 18:03:23
Power limit for GPU 00000000:09:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 4, 0A:00.0 GeForce GTX 1070 Ti, 6.40 W / 180.00 W (Default 180.00 W) === 18:03:24
Power limit for GPU 00000000:0A:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 5, 0B:00.0 GeForce GTX 1070 Ti, 6.49 W / 180.00 W (Default 180.00 W) === 18:03:24
Power limit for GPU 00000000:0B:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 6, 0C:00.0 GeForce GTX 1070 Ti, 6.77 W / 180.00 W (Default 180.00 W) === 18:03:24
Power limit for GPU 00000000:0C:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 7, 0D:00.0 GeForce GTX 1070 Ti, 6.18 W / 180.00 W (Default 180.00 W) === 18:03:24
Power limit for GPU 00000000:0D:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 8, 0E:00.0 GeForce GTX 1070 Ti, 5.85 W / 180.00 W (Default 180.00 W) === 18:03:25
Power limit for GPU 00000000:0E:00.0 was set to 126.00 W from 180.00 W.
All done.

=== GPU 9, 0F:00.0 GeForce GTX 1070 Ti, 6.02 W / 180.00 W (Default 180.00 W) === 18:03:25
Power limit for GPU 00000000:0F:00.0 was set to 126.00 W from 180.00 W.
All done.


#3

Even the Version before at a mixed Rig Nvidia/AMD i had the issue that sometimes the OV settings linked to the Wallet was loaded and sometimes not. The manual OV (The Big Buttons) at the Rig page settings always work for me. Even with the actual version.
Sounds like a bug wich can be easy fixed.


#4

Manually applying OC settings didn’t work either


#5

Thats strange. For me it work for my Nvidia GTX 1050 ti.
AMD i can not check cause my R 290 never react to OV from HiveOS.


#6

I faced the same problem. The problem was solved by manually installing the AMD driver pack. After that, NVIDIA overclocking started. AMD video cards in Riga no. sorry for the bad English.


#7

Interesting - thanks, i’ll give it a shot.


#8

Yes, latest image dont work(

Detected 8 NVIDIA cards
CLOCK = -200 -200 -200 -200 -200 -200 -200 -200
MEM = 1200 1260 1260 1260 1260 1260 1200 1260
FAN = 80 60 80 100 100 100 80 70
PLIMIT = 0 0 0 0 0 0 0 0

nvidia-persistenced failed to initialize. Check syslog for more details.
Persistence mode is already Enabled for GPU 00000000:01:00.0.
Persistence mode is already Enabled for GPU 00000000:04:00.0.
Persistence mode is already Enabled for GPU 00000000:05:00.0.
Persistence mode is already Enabled for GPU 00000000:06:00.0.
Persistence mode is already Enabled for GPU 00000000:0A:00.0.
Persistence mode is already Enabled for GPU 00000000:0B:00.0.
Persistence mode is already Enabled for GPU 00000000:0C:00.0.
Persistence mode is already Enabled for GPU 00000000:0F:00.0.
All done.

=== GPU 0, 01:00.0 GeForce GTX 1060 6GB, 97.30 W / 200.00 W (Default 200.00 W) === 21:55:03
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 1, 04:00.0 P106-100, 102.77 W / 120.00 W (Default 120.00 W) === 21:55:03
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 2, 05:00.0 P106-100, 103.65 W / 120.00 W (Default 120.00 W) === 21:55:03
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 3, 06:00.0 P106-100, 100.66 W / 120.00 W (Default 120.00 W) === 21:55:03
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 4, 0A:00.0 P106-100, 99.79 W / 120.00 W (Default 120.00 W) === 21:55:03
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 5, 0B:00.0 P106-100, 101.69 W / 120.00 W (Default 120.00 W) === 21:55:04
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 6, 0C:00.0 GeForce GTX 1060 6GB, 96.96 W / 200.00 W (Default 200.00 W) === 21:55:04
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

=== GPU 7, 0F:00.0 P106-100, 104.58 W / 120.00 W (Default 120.00 W) === 21:55:04
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)


#9

I am also having this problem where/how do you install the amd driver pack to solve the issue?


#10

I would not recommend update the driver manually!
If you do this the wrong way you stay at this driver version forever and the next HiveOS
updates of the driver will fail or best situation will be ignored.

I wait for an update.


#11

((((((((((

Thu May 17 03:48:55 EEST 2018

Detected 7 NVIDIA cards
CLOCK =
MEM = 250 250 250 250 250 250 250
FAN = 0 0 0 0 0 0 0
PLIMIT = 0 0 0 0 0 0 0

nvidia-persistenced failed to initialize. Check syslog for more details.
Persistence mode is already Enabled for GPU 00000000:01:00.0.
Persistence mode is already Enabled for GPU 00000000:02:00.0.
Persistence mode is already Enabled for GPU 00000000:03:00.0.
Persistence mode is already Enabled for GPU 00000000:04:00.0.
Persistence mode is already Enabled for GPU 00000000:06:00.0.
Persistence mode is already Enabled for GPU 00000000:08:00.0.
Persistence mode is already Enabled for GPU 00000000:09:00.0.
All done.

=== GPU 0, 01:00.0 GeForce GTX 1080 Ti, 253.03 W / 250.00 W (Default 250.00 W) === 03:48:55

=== GPU 1, 02:00.0 GeForce GTX 1080 Ti, 253.90 W / 250.00 W (Default 250.00 W) === 03:48:55

=== GPU 2, 03:00.0 GeForce GTX 1080 Ti, 237.64 W / 250.00 W (Default 250.00 W) === 03:48:55

=== GPU 3, 04:00.0 GeForce GTX 1080 Ti, 250.72 W / 250.00 W (Default 250.00 W) === 03:48:55

=== GPU 4, 06:00.0 GeForce GTX 1080 Ti, 253.69 W / 250.00 W (Default 250.00 W) === 03:48:56

=== GPU 5, 08:00.0 GeForce GTX 1080 Ti, 249.12 W / 250.00 W (Default 250.00 W) === 03:48:56

=== GPU 6, 09:00.0 GeForce GTX 1080 Ti, 245.55 W / 250.00 W (Default 250.00 W) === 03:48:56


#12

Я так в итоге и не понял - проблема именно с новыми драйверами нвидиа или проблема в сборке 0.5-51 ?


#13

Has this issue been solved by somebody?
How did you manually update the amd driver to solve the problem?

The problem comes from the “nvidia-settings” call that is used for overclocking.
This is what throws the
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)
error strangly.

It is used something like this normally:

nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1
nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[3]=100
nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[3]=500
nvidia-settings -a [gpu:0]/GPUFanControlState=1
nvidia-settings -a [fan:0]/GPUTargetFanSpeed=90

After looking into the /hive/sbin/nvidia-oc file, i noticed a weird way the “nvidia-settings” command is called - it gets a long string of multiple "-a " parameters, which i doubt is working, but dont know for sure…
In previous versions, “nvidia-settings” was called one by one with each “-a” parameter, as you can see is still in the file but marked as comment.

Tried downgrading (not below 0.5-07), tried reinstalling amd driver thats located in /hive-drivers-pack/ but nothing works…

Please help!


#14

How do u stop auto update on new flash disk


#15

After uninstalling AMD driver completely, Nvidia overclocking seems to work…
Why?
No mixed Nvidia/AMD support?


#16

Uninstalling the amd drivers worked for me


#17

I have this same problem i have to reboot with no overclock setting let the miner start then have to apply the settings while HiveOS is running and the system freezes every 12-16 hours now. I have 5 RX580 2 1080ti 2 1080 and 4 1070 running Claymore on the rig my other rigs are working just fine and no issues but they have only 1080ti and only 1070’s on them


#18

[quote=“zardozer;3783”]After uninstalling AMD driver completely, Nvidia overclocking seems to work…
Why?
No mixed Nvidia/AMD support?[/quote]

Just re-install HiveOS


#19

Latest Version: 0.5-53 image has fixed this for me. OC and fan settings now applying as they should.


#20

Did you do a clean install or just an upgrade?