Phoenixminer + 5700: 30% fan RPM after reboot unless overclocking template is manually set, why?

I have 14 RX 5700 rig using phoenixminer with Beta2 hiveOS. Rig works relatively fine, some GPU’s hang once in a day causing rig to reboot. While I have set fan speed to 40% in my default OC setting, rebooting rig changes fan speed always to 30% which causes my rig to overheat. Only thing that prevents this behaviour is that I apply my OC setting manually after reboot.

Why i’m getting this weird behaviour? I tried to disable phoenixminers fan control with “-tt 1” but that messes up everything causing ~30% invalid shares and rig rebooting

any help would be appreciated